Range Rovers Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter · #1 ·
I bought a used 2019 RRS about a year ago. So far, I love the car with one exception: the entertainment system/console is super glitchy. A few examples:
  • When the AC is on, and I set to recirculate the air, it often turns that setting off (the recirculate icon goes from being lit to unlit, and air from outside starts coming in)
  • Not infrequently, there's a long delay between when I start the car and when the top screen becomes active
  • Apple CarPlay is the worst. I often have to unplug and plug in again the USB cable connecting my phone to the vehicle a few times before it recognizes the phone and starts CarPlay. On a recent road trip, it was doing weird things like switching back and forth between different audiobooks in Audible without any user input from me. Other times, when I touch the screen nothing happens.
There's more, but this is a basic idea.

I know RRs have a reputation for poor electronics—does that extend to the console/entertainment system? Is there anything that the dealer might be able to do about this? I'm due for a service anyway soon.
 

·
Registered
Joined
·
28 Posts
FWIW, I don't think I've seen any car in the last 10 years that kept recirc on indefinitely.
 

·
Registered
2019-2021 Range Rover MkIV / L405
Joined
·
49 Posts
The newer firmwares help a lot with glitches, which software version do you have?

The infotainment speed won't improve much, the processor is an Intel Atom...

You should check the cable/connector, Apple CarPlay works flawlessly in mine and I even use a CPLAY2air wireless adapter...

Also: Recirculation - touch the icon to recirculate air inside the vehicle.
• Touch briefly to select timed recirculation. Recirculation switches off automatically after a set time (dependent on the ambient temperature).
• Touch and hold to select latched recirculation. Recirculation remains on until the icon is touched again.
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #5 ·
The newer firmwares help a lot with glitches, which software version do you have?

The infotainment speed won't improve much, the processor is an Intel Atom...

You should check the cable/connector, Apple CarPlay works flawlessly in mine and I even use a CPLAY2air wireless adapter...

Also: Recirculation - touch the icon to recirculate air inside the vehicle.
• Touch briefly to select timed recirculation. Recirculation switches off automatically after a set time (dependent on the ambient temperature).
• Touch and hold to select latched recirculation. Recirculation remains on until the icon is touched again.
Thank you, this is very helpful! How do I check the software version?

I've used a couple different USB cables, so I don't think it's that. The vehicle is still under warranty, and I'm due for an oil change, so I am going to have the dealer run a diagnostic on the system when they have it.

And thanks for the tip on recirculation. I didn't know about that setting.
 

·
Registered
2019-2021 Range Rover MkIV / L405
Joined
·
49 Posts
You are welcome! To check SW version: Settings (the 2 gear wheels in the menu bar)/All Settings/Software Update. Latest is 21A.
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #7 ·
You are welcome! To check SW version: Settings (the 2 gear wheels in the menu bar)/All Settings/Software Update. Latest is 21A.
Thanks again! For whatever reason, the first few times I tapped "check for update", it said "no update required". But on the third time, it found the 21A update.

However, it is taking forever to install it, and the energy management system keeps turning the vehicle off. When I turn it back on, it still says "Installing new software version", but I'm not sure if it got interrupted and is just frozen on the screen. Nothing seems to be happening.
 

·
Registered
Joined
·
4 Posts
Thanks again! For whatever reason, the first few times I tapped "check for update", it said "no update required". But on the third time, it found the 21A update.

However, it is taking forever to install it, and the energy management system keeps turning the vehicle off. When I turn it back on, it still says "Installing new software version", but I'm not sure if it got interrupted and is just frozen on the screen. Nothing seems to be happening.
Just let it install. When it is downloading the new software, it says "Downloading new software version" which takes longer than "Installing new software version". When completed it will tell you the software version installed and date of installation which should confirm that everything is installed.
 

·
Registered
2019-2021 Range Rover MkIV / L405
Joined
·
49 Posts
However, it is taking forever to install it, and the energy management system keeps turning the vehicle off. When I turn it back on, it still says "Installing new software version", but I'm not sure if it got interrupted and is just frozen on the screen. Nothing seems to be happening.
Make sure you have a good internet connection, either through the sim, or, better, close to your house's Wi-Fi... The updates aren't large (less than 50 MB), but a reliable connection is required for them to download faster.
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #10 ·
The update completed! I'll test CarPlay and other stuff and see if this fixed the problems. Thanks again for your help.
 

·
Registered
2018 L405
Joined
·
137 Posts
Don't get too excited, you're still going to get the occasional glitch and very slow start-up at times. Mine has occasionally lost the XM icon in sources, wouldn't pair to my mobile, and other wonky stuff like that, even on version 21.
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #12 ·
Well, it's still messed up. I will try another USB cable. Failing that, I'll have the dealership do a diagnostic.
 

·
Registered
2019-2021 Range Rover MkIV / L405
Joined
·
49 Posts
Well, it's still messed up. I will try another USB cable. Failing that, I'll have the dealership do a diagnostic.
I suppose you already tried both USB connectors... There are UIP modules available on ebay, but if it's under warranty the dealer should fix it.
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #14 ·
Yeah, since it's under warranty, I'm going to have them take a look. That will also qualify me for their pickup/delivery service, so I won't have to bring my car to the dealership for the oil change that I'm due for!
 

·
Registered
2018 L405
Joined
·
137 Posts
Gotcha. So, you're going to let some pimple nosed lot attendant kid drive your car to and from the dealership. I mean immature teenagers are so mature behind a high HP engine. What could go wrong there?
Hopefully they send an adult to pick up your car.
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #16 ·
They have a dedicated driver who is definitely an adult. And if anything happens, it's on them. I'm 35 min from the dealership and, yes, it's pretty nice to have a loaner delivered to my driveway while they take my car away, service it, and bring it back!
 

·
Registered
Joined
·
1 Posts
I have no idea why this fix works, but I found it after dealing with the same issues you are saying and was considering selling my RR. Go into settings and then general, go to CarPlay, and make sure Allow CarPlay while locked is turned on. It would not connect even when not locked but I turned this on and my issues went way down. Hope that helps!
 

·
Registered
2020 RR P525 HSE
Joined
·
33 Posts
Free Advice - Accept what you can not control.

There are numerous bugs in the USB-A console especially if you have a refrigerated cooler. The dealer will spin you around instead of just replacing that module, which seems to overheat when in use driving. I have been thru numerous USB-A cables. They work for a while then they don't. That module (module definitely won't act up at the dealership (it won't get hot enough in the diagnosis even with cooler on) - this also manifests as SIM unavailable, HOTSPOT unavailable.

In addition, Sedwars32 is 100% correct - CARPLAY (on your phone) has to be set to "Allow Car Play while LOCK on"
 

·
Registered
2020 RR P525 HSE
Joined
·
33 Posts
Free Advice - Accept what you can not control.

There are numerous bugs in the USB-A console especially if you have a refrigerated cooler. The dealer will spin you around instead of just replacing that module, which seems to overheat when in use driving. I have been thru numerous USB-A cables. They work for a while then they don't. That module (module definitely won't act up at the dealership (it won't get hot enough in the diagnosis even with cooler on) - this also manifests as SIM unavailable, HOTSPOT unavailable.

In addition, Sedwars32 is 100% correct - CARPLAY (on your phone) has to be set to "Allow Car Play while LOCK on"
I just found the USB-A part - for $125 https://www.unichip-tec.com/h-pd-249.html#skeyword=HDMI&_pp=0_35
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #20 ·
I have no idea why this fix works, but I found it after dealing with the same issues you are saying and was considering selling my RR. Go into settings and then general, go to CarPlay, and make sure Allow CarPlay while locked is turned on. It would not connect even when not locked but I turned this on and my issues went way down. Hope that helps!
Thanks for this. "Allow CarPlay while locked" was already turned on in Settings, so unfortunately this is not the issue.
 
1 - 20 of 20 Posts
Top