RangeRovers.net Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi guys I have owned my 2001 range 4.8 Petrol v8 for a day and I think I have broken it already !, all day it’s been fine I fulled into a turning to turn around, had to be quick as there was a car coming so ( can’t be sure but ) it was still rolling back very slightly when I put it in to drive and floored it, it pulled off for a second then all of a sudden there was no drive like it had poped out of gear ( no funny noises etc ) so back in reverse back in drive nothing, switch the car off and on, into drive and off it went but very slowly even though the revs were high, once it’s over 30mph ish it’s fine but from a stand still slow.

Clutch - electrical or worse any ideas ?
No dash lights present !
 

·
Premium Member
1970-1995 Range Rover Classic
Joined
·
455 Posts
I am confused... is it a manual which would be strange in a 4.6. But if you have a clutch, try to listen to slipping noises and check the adjustment.
If not, which the word drive makes me think, check your oil level in the auto box.
Check state of oil.
If state= disgusting or yeeeks, change it. Otherwise, top up.

PS as Mr Toad In Charge always says, please put you vehicle details in your profile, it really helps. Also your location.. For instance if you are in the US you are unlikely to have a manual box. If you are where I am, I know you never have heater problems :)
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
770 Posts
He means the clutch in auto box, I would certainly check you fluid levels first,.
slide under the car and crack the filler/level bolt, start up, run through every gear, then back to park, leave it running, now see if you can get any fluid in, not easy even with the squeeze bottles of atf.
do that first then let’s us know what happens,
 
1 - 3 of 3 Posts
Top