RangeRovers.net Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter #1
Topped off my oil last week as it was down a little bit; may have put a little too much in but nothing drastic. My wife noticed that the vehicle shakes while stopped. Very faint but if you put a piece of paper down it will vibrate (if that gives an idea what I'm talking about). It has not been shaking like this for ever but honestly I didn't notice it until she mentioned it. That said, she had not been in the vehicle for a week or so as we just had our son.

The idle is also under 1.

Anyone have any ideas?
 

·
Registered
Joined
·
1,806 Posts
Without knowing more, it is hard to say.

I'd say the most likely culprits are:

1. Vacuum leak of some sort
2. Dirty/Worn spark plugs
3. Ignition wiring
4. Motor/transmission mounts
5. Something amiss in the intake/fuel system

Most likely it isn't something major as long as you don't wait until more problems arise, however if you don't DIY, it could potentially be some expensive trial/error at the dealer depending on the skill/experience of the mechanic.
 

·
Registered
Joined
·
65 Posts
Discussion Starter #3
Huh. Well, could be the spark plugs as the RR have 65K on it, however, took a look & they are clean/fine. Am thinking it may have something to do with putting 87 in the gas tank rather than premium. Should not be something with the intake system though... sort of related; had my 2nd cat converter put in back in Feb.

Thanks
 
1 - 4 of 4 Posts
Top