RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Although, I don’t drive on the highway much, when I do I have a severe vibration above 65. It starts about 60 with a minor vibration but by 65 is a severe shake – it only got worse up to 70 when I slowed down. The vibration instantly stops when I take my foot off the gas pedal and will start again if the pedal is reapplied if the speed is still above 60.

The problem seems to have started after installing a body lift, although I did a lot of other work at the same time. I still have the original drive shaft with the rubber couple. The rubber couple looks old and probably isn't in the best shape. Would a body lift cause this such that I need to replace with double U-joint shaft? Should I just replace the couple? Or is there another likely cause?

Thanks
Clay
 

·
Registered
Joined
·
30 Posts
Discussion Starter #4
Thanks for pointing me in the right direction. Did the diagnosis tonight and viscous coupling is seized. (could not turn right front wheel when off the ground w/ parking brake one and transmission and transfer case in neutral) This also explains the tight steering at low speed, the wheel chirp at full lock in the parking lot and the busted CV 2K miles ago. I Really should have caught on sooner
 

·
Registered
Joined
·
5 Posts
Hi,

it's good to hear that my experience with the borg warner is of some benefit (as for me, I still need to get my hands on a better tranfer box... I am considering buying a complete one (rebuilt),
f.i. through
http://www.ashcroft-transmissions.co.uk ... at&catId=5

(I just sent Ashcroft an email to inquire about the costs of delivery of these boxes to Continental Europe and to the States)


or just the viscous coupling to save some time and cash
f.i. through
http://www.island-4x4.co.uk/transfer-vi ... -1575.html
(a complete rebuild may be wiser...)
 
1 - 5 of 5 Posts
Top