RangeRovers.net Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
So I just passed the 6K mile mark on my 2016 TD6 and I am getting a service required message. In vehicle info it says that I am due for an oil change, which makes no sense since the first oil change is supposed to be 16K miles or 1 yr. My vehicle was delivered in early February 2016 and built in early January 2016. Checked oil level and it is reading only 1/8 below full. DEF says fill in 3,500 miles, which is about right. Any ideas?
 

·
Administrator
Joined
·
27,803 Posts
The service interval was most likely not cleared during PDI. A few folks have had this issue with new rigs. Unless the CEL is illuminated the dealer can just reset it while you wait.
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
91 Posts
Yep. Same thing happened to me but at 7000 miles. Dealer just had me stop in when convenient and reset the interval. Said he's seen several pop up early.
 

·
Registered
Joined
·
160 Posts
I have a 2015 SCV8 and have this message after performing the 1 year interval. They can't get the service required light to stay off, even though it was just performed at 1 year/12k miles. In the shop today to try and address it.
 

·
Premium Member
Joined
·
1,425 Posts
RRSLVR, you need to get out more! There are great places for day trips into NJ/CT/PA and get a few more miles on that RRS `)
 

·
Registered
Joined
·
321 Posts
I had the message come up around 5000 and I had the service performed i had the pre paid maintenance. I had this done as the break in oil to be replaced around 5000 anyways.
 

·
Registered
Joined
·
268 Posts
So I just passed the 6K mile mark on my 2016 TD6 and I am getting a service required message. In vehicle info it says that I am due for an oil change, which makes no sense since the first oil change is supposed to be 16K miles or 1 yr. My vehicle was delivered in early February 2016 and built in early January 2016. Checked oil level and it is reading only 1/8 below full. DEF says fill in 3,500 miles, which is about right. Any ideas?
Guys...this warning light is set to go off appx 12 months after the vehicle's build date. I had a long talk with a good LR technician and he explained what this is about. Mine did it exactly 12 months from its build date. At some dealerships they call it the "Birthday Notice".

Don't sweat it...it happens to most of us. The tech just needs to reset it. 100% normal.
 

·
Registered
Joined
·
160 Posts
There is actually a bulletin about it not resetting and staying reset until the next interval. This was my issue. There is a software fix: LTB00871NAS3. Mine was reset after service and came right back on. It appears fixed after this bulletin, but time will tell.
 

·
Registered
Joined
·
44 Posts
Discussion Starter #10
Guys...this warning light is set to go off appx 12 months after the vehicle's build date. I had a long talk with a good LR technician and he explained what this is about. Mine did it exactly 12 months from its build date. At some dealerships they call it the "Birthday Notice".

Don't sweat it...it happens to most of us. The tech just needs to reset it. 100% normal.
As I indicated above, my RRS was only built 5 months ago, so it is not a "birthday" notice. The dealer said to bring it in and they will reset it. I will have to inquire about the software fix.
 

·
Registered
Joined
·
268 Posts
As I indicated above, my RRS was only built 5 months ago, so it is not a "birthday" notice. The dealer said to bring it in and they will reset it. I will have to inquire about the software fix.
Hey Jim....have you been taking your Rover to Coleman in Columbia or over to Annapolis? Just curious about your experiences with the service team. I've had decent luck over in NoVA. Always good to have a back-up dealership.
 

·
Registered
Joined
·
44 Posts
Discussion Starter #12
Actually, I live in Northern Baltimore County, so the closest dealer is Hunt Valley. I have had good experience with them over the past 15 years.
 
1 - 12 of 12 Posts
Top