Range Rovers Forum banner

seat controls, tilt, tele gone

14435 Views 21 Replies 11 Participants Last post by  Naki
We have a 2003 Epsom Green Range Rover. Purchased from private party about 2 months back. Wonderful car to drive.

Bought the vehicle with non-functioning wheel telescope function.
Then the tilt slowly failed, completely.
Then the Driver's seat memory went.
Then the rest of the controls on the driver's seat went. Slowly. But gone.
Oh, wait, the Lumbar Adjuster still functions! And the seat heater!
And the adjustment its stuck at ain't too bad, for me.
The passenger seat all works fine, which makes me think the Seat Computer, located under passenger seat is OK. Maybe?
My amateur guess is the switch itself. So I carefully wiggled the trim cover off, breaking most of the tabs.
Unplugged the connectors, wiggled all the rest, nothing.
Fuse 20 is fine.
The RAVE I downloaded is cumbersome in that I don't know how to find answers to questions like this so far. So if any fans out there have suffered similar issues, and found relief, and would be kind enough to share it, I would be most grateful.
Pacifica, Ca
1 - 20 of 22 Posts
Not clever enough to know how to update.
By reading the RAVE diagrams, we jumped power into the seat computer/memory switch, and the seat slides and tilts as it should.
Have ordered a used computer, and await it eagerly.
The telescoping steering column issue has been traced to the old broken white clip condition. Dealer said they only sell the clip along with the whole motor.
So I have ordered (2) individual clips from England, hoping my motor still works. We'll see.
By the way, Redwood City Land Rover gave the best price on a new Interstate battery of 4 dealers I phoned, and better than the Independent Battery dealer I usually patronize.
Received the Seat Switch / Computer from Roverland (Thank you).
Installed it, got the trim cover with its broken clips to stay put, and now the Driver's Seat slides, tilts, raises, lowers as it should.
I'm not playing with the Memory buttons till I get the Telescopic Motor Clip and dig into the Steering Column.
Dealer told me the plastic clip could not be ordered separate from the tele-motor ($$), so I ordered (2) from Brit-Car (UK) for a few dollars/pounds.
Now I await that package...
Which part did you order for steering tilt problem?
Sorry for slow reply. I got the part #'s from rangerovers.net Steering Column Fixes page--I don't have my order in front of me, but I'll post in a day or so. I ordered the Clip (white plastic) which holds the motor from twisting, the Special Grease, and the Special Tool which (apparently) holds the Threaded Rod from spinning whilst being installed (I'm guessing here--I haven't seen it yet)
Brit-Car Uk says its being shipped now. It all cost around $30 plus shipping. I actually ordered 2 clips in case I get to fix someone else's, or I break a clip trying to slide it in...
We'll see how it all goes together...
Last night my Battery Warning Symbol lit up, and won't go away. I have a new battery from Dealer about 3 wks old.
When/if I get home, I'll test Alternator.
Parts Ordered for Steering Column Telescope Repair:

Nylon Bracket QYH 500030
Tool QME 500100
Grease QYL 500010
Thaks for response;
What is your problem about steering column?Is it tilting or reaching problem?

I need a part to cure tilting issue;so i am not sure about this part.
Symptoms include inoperative Reach Function. I bought the vehicle in that condition, after reading on these forums about the common, expensive Steering Column Issues, the Seller gave me over US $1000 off my purchase price.
I do not yet have experience removing, fixing and re-installing the Column, but hope to be expert soon.

Right now I believe I'll be replacing my Alternator. The Range Rover rode 60 miles on a Transporter last night, after my Battery Indicator (big red dash symbol) lit up and I TRIED to ignore it.
After I started sweating, I pulled over and the AIR SUSP INAC, and TRANS FAILSAFE MODE and HDC INAC (I think, I was a little stressed) . The throttle raced, up, down,up, down, maybe 1000-2000 RPM with NO movement of the Tachometer, until I shut it off. Lights dimmed, Wipers slowed, Windows, slowed, car fogged up ( we may have been breathing harder) Quite exciting.
Put battery on 2amp charger and moved it this morning, Dash Light showing Battery Symbol still lit.
My Battery is 3 weeks old, and I had NO lit symbol before replacing it.
Time for a new Belt, Alternator and Coolant???
See less See more
The saga continues...
Did the Alternator (you do know it's water-cooled, right?), did both belts and the Water Pump at the same time. There was noticeable slop in the Water Pump, so while at Redwood City Land Rover, they asked if I'd like to FEEL how good a new one feels. That sold me. With the gasket and 3 O-rings under $350.
Put it all together, filled it with my new BMW $20/gal blue coolant...and had forgotten to attach lower hose on the Water Pump. I really like those BMW hose connections, and the "snap" they make when you connect them. I have been living in the Dark Ages. My other drivers are 1967 Econoline Van, chopped into a pickup, and my 1940 Chevrolet Pickup (5.7 l , fuel injected, 700R4 etc), so its all about hose clamps. Of course, their Alternators are only a hundred bucks. I didn't do the $1600 dealer price--I went to Alternator Starter Exchange in SF and paid $360 plus exchange-- we'll see how that goes.
The weird thing is, when we put the battery connection on ( it IS now charging!), the Steering Wheel Tilt now works.
Still waiting for clip for Reach Motor...
See less See more
Back to the TILT/TELE issue.
Received the Clips for the Telescoping/Reach Motor from Brit Car UK. They shipped quickly but it took almost 2 wks to receive. Bought Tool to spin Reach Motor, two Clips ( they were cheap, but thought I might break one?), and special French Grease. All about $30 shipped.
Removed Column Cover, 3 Torx.
Pulled Column per Rave, took 45 minutes for two guys.
Installed Motor with Clip, maybe 3 minutes.
Stuck Column back in.
STRUGGLED to get all 4 bolts to attach Column under dash. The Tele Motor was NOT IN THE WAY on the way OUT!
Then forgot to plug the Tele Motor in!
Spent an hour trying to plug it in because we just didn't want to face those 4 bolts again.
Borrowed nice long needlenose from my neighbor to plug it in.
Fired it all up. Memory et all work great!
Do you need the QME 500100 tool when you replace the nylon bracket?
My bracket broke and the telescopic motor assembly just fell off. I have
disconnected it from the wiring harness for now and remove it so it does
not obstruct the steering column.

I bracket is available from our local RR dealer, but the QME 500100 is not.
It is a "shop tool" and not to be ordered by non-dealers.
By nylon bracket you meant this one: http://www.upload.ee/image/2817557/2012-11-10_20.54.39.jpg
the in and out (reach) adjustment motor holder/bracket?
Where do you get a new one?
I have exactly the same problem with the seat controls as you did. As a temporary fix, what wires/connections did you jump out? I have the RAVE diagrams. Any help would be appreciated.
Greenpoupon, when you say that you replaced the "seat switch/computer" did you replaced the black switch pack on the driver's side or the computer under the pass. seat?
Greenpoupon, when you say that you replaced the "seat switch/computer" did you replaced the black switch pack on the driver's side or the computer under the pass. seat?
GP has not been online in almost 3 years.
I thought so, I sent him a PM with no response.
Thank you!
I think I answered my own question!! I just replaced the seat switch pack and problem solved!!! The column and the seat move as they should!!
Zubi, thanks for your input here. It helped me get my seat/steering column back to normal working condition. Now to 'disarm' the memory for the steering column with my Allcoms. For anyone interested, I purchased my seat control from here: http://www.landroverpartsinternational.com/index.cfm . Price with shipping was about $60 less that I saw on ebay for new OEM. I had also purchased an external door latch cable from them that I had difficulty finding elsewhere at the time I needed it.
The biggest problem I had was unplugging the main wiring plug from the back of the control unit. It was a bugger.
Thanks to the forum.
Hello Zubi, the problem I'm having is that the seat will move forward but to getit back takes forever, I have to keep pushing until it decides to slowly move back. (Very annoying) was this similar to your problem?
Does anyone know the part number and best place to buy the seat control for the drivers side of my 2003 RR HSE>
1 - 20 of 22 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.