RangeRovers.net Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi everybody. I've searched but I can't find a thread that matches my problem - please forgive me if I've missed it.
When I bought my '07 2.7 diesel HSE sport the SatNav disc was put in the glove box by the dealer from his file.
I installed it into the player/reader and it soon showed my location.
I can set route preferences, choose scale, set home and so on.
Indeed I can even use the map to select a destination and it plots a route and starts guidance!
But if I press the 'enter postcode' or 'enter address' buttons they click and dim but no entry page opens up.
I tried a European disc but it's the same result so I'm guessing not a disc problem
Am I missing something simple here please?
Many thanks for any advice
Richard
 

·
Premium Member
2006-2009 Range Rover Sport
Joined
·
517 Posts
Not sure if my issue was the same but I could not get my nav to find any city in Ohio (I love in Virginia). After a good bit of messing with the menus I found i needed to change the region to north east or something. Once i did that it worked great. Not sure how it works in the UK but maybe you are just outside the postal code you are looking for. Oh well, Best of luck.


'06 RRS LUX
'06 pilot EXL
'91 4runner
 

·
Registered
Joined
·
226 Posts
I vaguely remember that the default region for European (incl. UK) Land Rover GPSs is Belgium for some reason. Set the region to UK and you should be fine.
 
1 - 3 of 3 Posts
Top