RangeRovers.net Forum banner

1 - 3 of 3 Posts

·
Registered
1995-2002 Range Rover P38A
Joined
·
3 Posts
Discussion Starter #1
It has failed its emissions test at MOT on CO excessivelyhigh something like about 5.5 on petrol (it was difficult last year to getthrough), HC were under the 200mark. It has LPG and that runs OK andits emissions are fine on LPG which is what I suspected.
It blew a cylinder head gasket about 8 months ago and nowwondering if (one of ) the CATs were damaged. It had new plugs and leads at the time too.
It has 180k miles but engine replaced some years ago (don'tknow when). Its mint inside the engine(both heads were cleaned anyway whilst off), does not burn oil, pulls like atrain, has clean oil and clean air filter. I had the injectors cleaned and tested about when the heads were off andall were within about 5% of normal and they were all cleaned. It has new air filter too this week again.
Cant find any inlet manifold air leaks. It has had two new O2 sensors and reartailpipe exhaust silencers were replaced due to crack near Y piece beforetest. PS did not do any map resetting,.

I have done diagnostics with my Faultmate MSV, only shows drive cycle required and above camshaft problem but that's been there for 6 years.

MAF sensor looks OK, and clean. Camshaft sensors is in fault (p1000 I think)have changed it twice but no avail, understand its likely to be residualmagnetism to the cam sprocket necessitating a stripdown again so not doing that. Only other issue is one slightly noisy tappetat tickover.
I think its over fuelling in petrol
So only thoughts now are :-
1) CATS (may be damaged by head gasket failure with coolant,or may be just old now - don't know if ever replaced)
2) Engine coolant temp sensor (understand there is aseparate one for the gauge) and the gauge reads OK,
3) Coil packs (but don't believe so since the HC arereasonably OK)
4) MAF
thoughts on whats best to do now as at a bit of a loss.
Mark
 

·
Super Moderator
Joined
·
2,319 Posts
First of all, if the emissions are OK on LPG and you presented it for test running on LPG, the emissions on petrol are irrelevant. It will pass the MoT and ordinarily if tested on LPG nobody would bother to test on petrol. The only exception to this would be if it failed on LPG then a tester may choose to test on petrol to see if it will pass on that. However, that doesn't answer the question, only that you should have passed the MoT. Talk of injectors makes me assume that the LPG system is a multipoint with an injector per cylinder. In which case it will be slaved off the petrol system. The way it works is that the LPG injectors need to be open for longer than the petrol injectors so the system intercepts the pulses from the petrol ECU (that would ordinarily fire the petrol injectors), adds a fiddle factor and pulses the LPG injectors for that time. So, assuming that at a particular load and revs the petrol injectors need to be open for 8mS, on LPG they may need to be open for 11mS. The LPG ECU adds this 3mS according to the saved map. However, if it is adding only 1mS, then the engine will run weak so the petrol ECU will adapt and increase the injector pulses to 10mS to get the mixture correct again. Fine when running on LPG but when you go back to petrol then it will be running rich. If you run it just on petrol then it will gradually readjust and get things back as they should be. You need to adjust the mapping in the LPG ECU.

An easy way to check is to see what the trip computer shows the MPG figure when running on petrol and when on LPG. As the trip computer calculates the fuel consumption from the injector pulse lengths, it should show the same MPG figure when on petrol as when on LPG. If it shows a lower figure when on LPG, that suggests the LPG system is set too lean (too small fiddle factor) and it is increasing the petrol pulse lengths to compensate, if it shows a higher figure then it is set too rich (adding too large a fiddle factor) and the petrol ECU is having to adjust the other way. Or, just use the Faultmate to read the long term fuel trims.
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
3 Posts
Discussion Starter #3
Thanks for the info. Understand where you are coming from.
Yes its a sequential system, LPG injectors signals are taken in line from petrol injectors into LPG brain along with both (RH / LH bank) O2 sensors and then LPG ECU triggers each individual LPG injector.
Given LPG side is OK there cant be too much wrong with the engine itself.
However, had done about 60 miles on petrol only, most of which was at 60-70mph ish before hand so I would have expected the ECU to fully trim back to petrol only from LPG. LPG was off anyway.
I do know about the test on LPG gives a pass and I have an MOT certificate as a result, but the fact remains it failed on petrol. SO there is something not right on the petrol side and I would like to get it resolved.
 
1 - 3 of 3 Posts
Top