RangeRovers.net Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Just got my RR2018 HSE a month ago and has been at the service center 3 times.

Since the beginning I couldn't deal with how slow it was compared to the one I test drove, being the main problem an acceleration lag whenever I use the brake for a few seconds (example: Stop signs, turning left in a two way street and getting out of a line of cars) and after releasing it, the engine takes 3-4 seconds to respond and the car woould just move by innertia no matter how deep you step on the pedal. Finally after this time (2-4 seconds, enough for many other cars to reach 60mph), the engine would engage at whatever acceleration you'd have summoned but it's not like the car would move that fast either, and the RR would finally start moving forward. (note that all this without activating the autostart).
This was not the main issue, the airbag light decided to stay on all the time. The seatbelt wasnt responding accordingly and now that I think about it, these two might have been related.
The Autostop was not working or works whenever it pleases.
Yesterday whenI dropped the car, I drove around with one of the mechanics to show him this because no one could discover or reproduce this issue over there.

And to put a cherry on top, the last time I picked it up, before I dropped it yesterday, one of the speakers started to sound blown with bass intense music.

About this acceleration problem, what could this be and what would you recommend I should do?
 

·
Registered
2016-2018 Range Rover MkIV / L405
Joined
·
47 Posts
Re: RR 2018 HSE accelaration issue

I had the same issue with a Evoque...now I have a RR HSE Td6, which is pretty much the same, but I assume that is because of the diesel engine.
I never owned a diesel vehicle before, so I cannot compare, but the lag is something that bothers me a lot as well. Usually that happens with turbo charged engines, with less powerful engines (like 4 and 6 cylinders).
 

·
Registered
Joined
·
151 Posts
Re: RR 2018 HSE accelaration issue

Happens on the SCV8 also, hesitation from a stop. I believe it's from them gaming the emissions tests to reduce consumption from a stop.
 

·
SUPER MODERATOR
2010-2012 Range Rover Sport
Joined
·
1,986 Posts
Maybe you have eye sight / vision problems? Give ample room or time when making a left turn. No amount of V8 or V12 power is enough acceleration if you try last minute or miscalculated left turns.
 

·
Registered
2013-2015 Range Rover MkIV / L405
Joined
·
599 Posts
Re: RR 2018 HSE accelaration issue

Carac,
Is your SC a 2018? I have never had any problem with my 2013.
Steve
 

·
Registered
Joined
·
117 Posts
Re: RR 2018 HSE accelaration issue

My car has the same problem, and it's not eyesight. Its a VERY LAGGY pedal on slow rolls and honestly it's dangerous. Rover knows about it too...they haven't come up with any fix.
 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
101 Posts
Re: RR 2018 HSE accelaration issue

Carac, when you select dynamic driving mode does it resolve the acceleration hesitation from a stop?
 

·
Premium Member
Joined
·
1,840 Posts
Re: RR 2018 HSE accelaration issue

Yes, dynamic mode should solve it. The default COMFORT mode is not as agile as the previous default (Normal Mode) used to be.
 

·
Premium Member
Joined
·
1,309 Posts
Re: RR 2018 HSE accelaration issue

I had the same issue with a Evoque...now I have a RR HSE Td6, which is pretty much the same, but I assume that is because of the diesel engine.
I never owned a diesel vehicle before, so I cannot compare, but the lag is something that bothers me a lot as well. Usually that happens with turbo charged engines, with less powerful engines (like 4 and 6 cylinders).
I test drove a TD6. Much slower from a stop than even my 3.0 SC. I can't say it's slow by any means though.
 

·
Registered
Joined
·
117 Posts
Re: RR 2018 HSE accelaration issue

Putting the car in dynamic and sport doesn't really do much for it either. Maybe a little bit, but barely.
 

·
Registered
Joined
·
1,171 Posts
Re: RR 2018 HSE accelaration issue

I’ve had my 18 for 4 months and 2000 miles and it has the Acceleration lag from stop. The other problem is, when it finally decides to go, it takes off quicker than I would want it to so I have to take my foot off the Gas, I can’t modulate it. It’s not safe.

so now, after starting the engine, I turn the stop/start off and set it to Dynamic, it then drives perfectly, no Lag at all. Of course, I shouldn’t have to do this, there is definitely something wrong.
 
1 - 11 of 11 Posts
Top