RangeRovers.net Forum banner

1 - 3 of 3 Posts

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
515 Posts
Discussion Starter #1
Just replaced the EAS compressor with a new WABCO unit from Atlantic British, and Truck will not go into access mode.
1) Go's into extended mode.
2) Go's into Highway mode after staying at HWY speed for a few minutes.
3) Will not go into Access Mode. When I press the button, I only hear it exhaust air for a few seconds.

I do have two codes that won't clear with my Foxwell Scanner:
1) 08 High Pressure Exhaust Valve Fault
2) 18 Hight Pressure Exhaust Valve Supply Fault
I did not have these codes prior to installing the NEW compressor.

Prior to replacing, all height modes worked fine, compressor would just throw a Temp fault after a few minutes.

I am guessing I need different diagnostic software to clear codes and reprogram the computer for the new compressor???
 

·
Registered
Joined
·
19 Posts
To go into access mode, the compressor needs to let out all the air.
When its deflating, if there is a restriction, it can throw up a fault and sometimes thinks it hit a rock so goes into extended ( i think)
Try this .. remove the exhaust muffler on the compressor .. and see if it goes into access mode.
Its the small conical brass color screw on part to the front of the compressor
 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
515 Posts
Discussion Starter #3
Compressor was defective. AB sent new replacement, all codes cleared and all height profiles work.
 
1 - 3 of 3 Posts
Top