RangeRovers.net Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Reman Engine/New Other: Part (to Full) Stall at 1100 to 1400 RPM

okay, this is perplexing me. I have a remanned engine, new distributor, all new electronics (no bleeds, strong ohms / current), MAFS that is new, and even tested other ECMs to make sure it was not the problem and the engine just dies off at 1100 to 1400 RPM. It doesnt always can out, but it loses power readily. As if the pistons just stopped working. strange. I can rev past it most of time and get it above 1600 RPM where it runs beautiful again. IDles fine. Fuel filter fine.

Looking at usual suspects, I would think the problem would show itself in other RPM ranges. vacuum advance appears well, plenum is remanned and doing well it seems. Who knows, maybe its in these or something else.

I have asked other engine experts and they are scratching their heads, also.

Any help/ideas or knowledge of the potential problem would be greatly appreciated.

Thanks,
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
1,118 Posts
Re: Reman Engine/New Other: Part (to Full) Stall at 1100 to 1400 RPM

It's obviously turbo lag...

Some guesses from me:

Get a few k's up on the engine and see if it goes away

Use a timing light to check that the vacuum advance and the centrifugal advance is working and within specs - the rev range does point a little to the centrifugal advance

Check the ECU is getting a signal from the coil for RPM

Check the fuel pressure regulator
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Re: Reman Engine/New Other: Part (to Full) Stall at 1100 to 1400 RPM

Thanks for the reply!!

Well, early this morning. We disconnected the MAFS, and everything hit fine, no problems. Reconnect it, and boom, the 1100 to 1600 RPM drop off goes right in. Tried it with 3 other re-conditioned (in good shape) MAFS... So not sure if still other stuff you suggest or this indicates something else.

Going to go through your suggestions today, also.


Thanks for the insights! Let me know if you have others. much appreciated.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Re: Reman Engine/New Other: Part (to Full) Stall at 1100 to 1400 RPM

not sure if put in anywhere. on a 1995 RRC (county) SWB
 

·
Premium Member
1970-1995 Range Rover Classic
Joined
·
367 Posts
Re: Reman Engine/New Other: Part (to Full) Stall at 1100 to 1400 RPM

Is this a possible problem with the throttle position sensor?
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
1,118 Posts
Re: Reman Engine/New Other: Part (to Full) Stall at 1100 to 1400 RPM

If it is running without the MAF signal then it is on the default ECU map and suggests that TPS and RPM input is good. Do you have a spare ECU you can try?

The ECU gets RPM info from the coil so check that connection as well - unlikely but easy to check.

Any fault signals on the ECU?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Re: Reman Engine/New Other: Part (to Full) Stall at 1100 to 1400 RPM

tried about 3 ECMs !! Crazy. no faults. will check out that connection. I thought was ECM issue also, but doesnt make sense that happpens against all the others - as far as i can tell. who knows. maybe i need a 4th ECM!

Did input a TPS crossover for 22 bucks. Maybe need to get specific RR TPS.


trying fuel pressure regulator and few other items today. This one really has me.
 
1 - 7 of 7 Posts
Top