RangeRovers.net Forum banner

1 - 3 of 3 Posts

·
Registered
2016-2018 Range Rover Sport
Joined
·
54 Posts
Discussion Starter #1
IMG_1206.JPG

So, I got this warning this morning on my 2018 RRS TD6 while driving down my driveway. After noticing much reduced power, I stopped the engine, opened the door, and restarted it. All was normal then. I put in an email to my dealer, but it’s Sunday. Not loving this warning on week 3 of owning it.


Sent from my iPad using Tapatalk Pro
 

·
Registered
Joined
·
10 Posts
2017 RRS HSE v6 here. This happened to me last week in the morning driving out of my house. So that seems to be a pattern. It was driving fine then few minutes into the drive this happened. Pulled over, stopped the engine for 1 minute, started again and everything was fine. Drove to the beach after that and have not seen it since.
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
54 Posts
Discussion Starter #3
2017 RRS HSE v6 here. This happened to me last week in the morning driving out of my house. So that seems to be a pattern. It was driving fine then few minutes into the drive this happened. Pulled over, stopped the engine for 1 minute, started again and everything was fine. Drove to the beach after that and have not seen it since.
Mine was reportedly a "vacuum seal leak in the turbo system". After a trip to service all is good. Might not be a systemic problem though, we have different engines. Mine is the 2018 TD6.


Sent from my iPhone using Tapatalk Pro
 
1 - 3 of 3 Posts
Top