RangeRovers.net Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I have a 2009 RR SC and got this error today, which essentially limits my ability to even drive. Has about 60k miles on it.

these are the error codes.

p0301 Cylinder 1 misfire
p0308 Cylinder 8 misfire
P0300 Random Multiple Misfire
p0316 misfire on startup
p0201 Injector malfunction cylinder 1


What could this be? fuel filter? spark plugs? MAF?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
it just started, after going above about 15 mph it triggers, then it just sputters because the cylinders are not firing properly I assume. Never drive this thing aggressively
 

·
Registered
Joined
·
631 Posts
The 2006 supercharged models had the intercooler electric pump wired backwards from the factory, and would cause this issue as the intake air temp would increase under load and cause misfires.

I think they fixed the wiring by 07 though. And it only happened when driving aggressive or towing. Had to heat things up. Not the issue your having.



Sent from my Nexus 6 using Tapatalk
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
bad fuel? or clogged injector? I wonder if some 100 octane could flush it just to see if thats the issue
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
Does anyone know if cylinders 1 and 8 are connected on the coils down the line? Or are they all separate? I'm thinking it could be a spark plug/wire coil issue or maybe it's just something is up with that one injector.

Also, the injector fault code says it's a faulty circuit.
 

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
610 Posts
i am still dealing with this.
i have a 2006Sc but the electric pump is not a deal for me.

i have misfires on 7-8 and 1-2
sometimes the turck is shaking especially on cold weather conditions.

and i have warming issues, if i dont push with my foot on acc. pedal the engine is not warming itself, interesting car with interesting problems.
 

·
Registered
Joined
·
3 Posts
I have the same issue. 2006 SC has misfire on 1,5,7 and goes into limp mode while standing and raving up to 3000rpm. changed pump injectors coils plugs and still no joy. This all happened after i changed the right hand exhaust manifold. any ideas.?
 
1 - 11 of 11 Posts
Top