RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter #1
Greetings,
I have a 1989 Rangie.
My battery light came on the day before battery died.
AAA came and suggested that my alternator should be replaced.
The Kirkland Costco battery is 31 months old.
I replaced the alternator with a reconditioned Lucas Alternator.
The new alternator had one less connector. (the pig tail on the white wire of the Classic harness does not have a connector on the alternator).
The Rangie started with a jump and worked fine for two days.
On the third day, the battery was dead again.
Before I go get a new battery (optima this time).....
What does one suggest I do with the free pigtail connector?
Any suggestions?

Cheers!!
Savvy
California
 

·
FOUNDING MEMBER
Joined
·
4,509 Posts
not sure about the wiring, but Optimas are not all they're cracked up to be. Interstate makes a great battery for 1/3 the price, or Oddesy if you want to spend on a great battery. I abuse my battery and it's been ticking for 4 years (touch wood).....
 

·
Registered
Joined
·
1,395 Posts
Do you have a wiring diagram for that part of the car for your year?
 

·
Registered
Joined
·
47 Posts
Discussion Starter #4
Yes, but that doesn't help.
The original alt had a connector for the pig tail. The new alt does not.

BTW, Costco gave me a new battery at no charge.
 

·
Registered
Joined
·
1,395 Posts
But doesn't it show what that wire is connected to, and then hopefully what it does, and then where you could re-wire it to if you still need it...?
 
1 - 5 of 5 Posts
Top