RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello All -

First time poster, but long time viewer. :)

I'm currently leasing a 2018 Velar P380s Dynamic which I love, but it seems to have its fair share of issues so far.

The issue I'm currently having is when the air/climate is set in the front to a cold temperature, the rear vents are blowing piping hot air. The front is comfortable, cold, and the back is blowing engine hot air. There is no rear climate control settings in the main climate dash screen in my model, not sure if that's the issue. If I put the system on Max A/C, cool to cold air starts to come out of the rear vents, but thats the only time, the thing has to be on full full blast. Otherwise, its blowing hot air. Really stinks for the person in the back.

I recently brought it in for service to update the screens since I was having issues there, they swapped out the top radio all together, and reviewed the rear a/c but it seems it still persists after a week in the shop. I haven't spoken with them yet, but it seems nothing was changed or fixed with the rear a/c.

I'm wondering if folks are having similar issues??! Could it be that it just blows hot air unless on max a/c? This seems absurd in a luxury vehicle.

Thanks!
 

·
Registered
Joined
·
1 Posts
The exact same thing is happening in my 2018 Velar. I also don't have the rear climate control in my car. My dealer is telling me that it is a design issue for cars without the dual climate control and they are trying to figure out if there is a fix. Meanwhile today makes 23 days my Velar is in the shop. With little to no communication from my dealer. I'm paying $900/Mo. to drive an loaner Evoke that has 30,000 miles and ironically the Drivers side A/C vent on the loaner does not work. I'm new to the brand and I had heard Land Rover Service was bad, but I heard wrong they are horrible. I leave messages, emails, texts and they get back to me 3 days later. So disappointed in the brand right now. The car is beautiful but I don't think I'll ever buy another Rover again after this lease is up.
 

·
Registered
Joined
·
55 Posts
Chiming in...have a similar problem with my 14' RR-Sport...yes i know different model but with mine during the summer I'd get piping hot engine air from the left side drivers vents and no matter what i did it just kept blowing hot. Only way to fix was to close the vents. Also noted center console behind a/c controls and CD changer was hot to the touch. Would continue for a while then mysteriously stop. Local Independent shop said something about valves getting stuck but said they usually release after awhile driving. Fast forward now winter and they have stopped and get warm hot air I want out of vents...during Fall it would blow blow hot air 50/50 no matter what the climate setting. Not sure what is going on or why this happens but maybe its a design flaw or maybe its just Land Rover Service themselves. Good luck with that....
 
1 - 5 of 5 Posts
Top