Range Rovers Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello

I have a problem with my 64 plate Range Rover Sport L494 driver side heated seat. It is not working at all, but all the others in the car are working fine.

My diagnostics so far are:
  1. The fuse can't be blown if the other three heated seats are working correctly
  2. I have removed the seat from the car and used an ammeter to measure the voltage on the wiring harness connector coming from the car for the heated seat element. There are 4 cables on the connector, live and neutral, then two others. The live and natural have a constant voltage of 14v across them, even when the seat is switched off. I therefore presume the other two cables are for a sensor/earth to switch it on and off?
  3. With the connector still disconnected, I then tested for an open circuit on the heater element itself. Sure enough, there was no resistance/open circuit.
To me, the above suggests that the heater element is at fault, which I do find surprising in a car that is only 5 years old with 60k miles on the clock. The seat is also in as new condition, so doesn't look like it has ever had a particularly hard life from an old owner!

I am happy to replace the heating element and it is relatively cheap. Does anyone have any ideas on how much of the seat needs taking apart to replace the element in the base of the seat?
 

·
Registered
Joined
·
1 Posts
Hello

Did you have any luck with this? My drivers seat has no heat at all so was looking to change my heating element but can’t seem to find any info on how involved it is?
Thanks
 
1 - 2 of 2 Posts
Top