Range Rovers Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
This is veru odd and equally annoying!

If i start the vehicle and do not put on the healights then the vehicle runs great and the automatic gearbox works fine.

If i start the vehicle and put the headlights on then the vehicle on works when i change the gearbox in the manual transmission selcted.

If i start the vehicle and do not put the headlights on and then half way through my journey turn the headlights on then i get the message HDC System Fault not avaibale then alot of lights comne on the dash and then I have to change gear manually again.

Also the front LED headlights are on when the key is turned even tho they are not on the on position in the cabin.

I think the vehicle has a bodykit fitted as the parking sensors on the front and rear do not work and in turn some one has wired up the headlights incorrectly.

Any help would be appreciated.
 

·
Administrator
Joined
·
4,021 Posts
Did a 2006 Sport come with LED headlights? They may have been added when the bodykit was added so who knows what has been done to the wiring. As you are in the UK, as of a few months ago, LED headlights on a car not originally fitted with them is an automatic MoT fail.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Did a 2006 Sport come with LED headlights? They may have been added when the bodykit was added so who knows what has been done to the wiring. As you are in the UK, as of a few months ago, LED headlights on a car not originally fitted with them is an automatic MoT fail.
Hi Richard

I think they have been added when a bodykit was fitted and i do firmly believe it is something to do with the wiring. I was unaware of the rules regarding LED lights and the MOT, I will contact my garage.
 
1 - 4 of 4 Posts
Top