RangeRovers.net Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello, my range rover with air suspension has dropped till the bumpstops. I went to the local dealer and he tried to have connection with the suspension ecu but he failed. The pump isn't making any noise and the two lights on the up and down switches flash. Is there another way to "go in" the ecu or is the ecu just finished.

Jeroen (Holland)
 

·
Registered
Joined
·
345 Posts
There is a ton of info on the Problems and Fixes page of this site. You especially need to check out manual operation of system, so you can check manually compressor operation, bladder inflation etc. Also check Rover Renovations, and Story Wilson has a website for troubleshooting and diagnostics. All this info should keep you busy for sometime.
 

·
FOUNDING MEMBER
Joined
·
4,509 Posts
the ECU is very robust, I've never seen a bad one. You probably have electrical issues, if the ECU doesn't have power it won't be able to make the compressor run.
 

·
Registered
Joined
·
49 Posts
G'day,

What happened prior to the suspension going into limp mode ?
Extreme articulation / up on a hoist / trolley jack, etc.
I'm thinking maybe you have a wheel sensor that has reported to the ECU an error - like it's exceeded its normal working parameters....

I had the very same problem and it turned out to be that the suspension wasn't immobilised prior to the car being put on a hoist.

Additionally, the wheel sensors (pedometers) can become damaged or dirt/water can cause them to fail.

Definately check the wealth in this forum......

Cheers
Rod
 
1 - 4 of 4 Posts
Top