RangeRovers.net Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello, my ECU isn't working and I just wanted to make sure that my seat position sensors are working correctly. I tried measuring the sensor resistance, while moving the seat, but my multimeter shows nothing most of the time and displays a value sometimes. Am I missing something, or the sensor is broken?
 

·
Registered
Joined
·
366 Posts
I have not disassembled the RRC electric seats myself, but from reading here on this forum, I doubt the system included positioning sensors (just note here we are talking 1971-1995 Range Rovers). What seems to be the common failure is that the antiquated NiCa battery which is soldered onto the ECU board leaks and wrecks the circuit board.

Since the ECU just has a few memory functions that are not essential for the seat operation people convert the system to drive the motors with a bunch of relays instead. Search on this forum and you will find.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I have not disassembled the RRC electric seats myself, but from reading here on this forum, I doubt the system included positioning sensors (just note here we are talking 1971-1995 Range Rovers). What seems to be the common failure is that the antiquated NiCa battery which is soldered onto the ECU board leaks and wrecks the circuit board.

Since the ECU just has a few memory functions that are not essential for the seat operation people convert the system to drive the motors with a bunch of relays instead. Search on this forum and you will find.
Thanks, but that's not what I was asking about. I know that my ECU is broken, what I am asking about is how the sensors in the seat are suppose to function ( they are there for sure, I checked the ETM).
 
1 - 3 of 3 Posts
Top