Range Rovers Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter · #1 ·
Gents,

I noticed on my '08 Full Size SC that when the wipers are in the Auto position, if it starts raining even heavy they won't go. If I manually activate the wipers once then put it back to Auto, the wipers operate and will vary the speed based on the raid. So they work correctly, they just take an initial manual push the first go.

Is this normal?
 

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
438 Posts
On my '08 FFSC, I just leave the wiper stalk in the second (auto) position and they just work when it rains and vary speed depending on how heavy it's raining and vehicle speed. No manual start needed.
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
222 Posts
Just a note its not recommended to leave the switch in auto mode all the time even when its dry, as the sensor works on light refraction it is possible that dust can activate the sensor and cause a sweep and scratch the screen, like i said recommended.
AuZZZie it could be your screen is dirty in front of the sensor and it doesn't work until you have swept the wipers cleared the sensor then they work normally?
 

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
187 Posts
Thanks for the good advice, Familyman. I've kept my wipers on auto since I got the rover and every once in awhile, the wipers activate in the dry. I thought my truck was possessed; which it may still be! But...I'll only turn the wipers on when it rains!
 

·
Registered
2013-2015 Range Rover Sport
Joined
·
101 Posts
I wonder if this is something that changed at some point...My '07 SC does NOT work unless manually placed back into auto mode. It's my understanding this is by deign so that it would not be triggered inadvertently or by dust as suggested or in a car wash if you forgot to turn them off. I think it's supposed to require you to put it back in auto mode after each time the car is turned off.

-John
'07 SC
 

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
187 Posts
Hmmm...my 07 RRSC wipers don't need to be turned off and back on when I leave then in auto. They work pretty well and have only turned on maybe three times when it wasn't raining during the last 5 years.
 

·
Premium Member
Joined
·
2,092 Posts
Gents,

I noticed on my '08 Full Size SC that when the wipers are in the Auto position, if it starts raining even heavy they won't go. If I manually activate the wipers once then put it back to Auto, the wipers operate and will vary the speed based on the raid. So they work correctly, they just take an initial manual push the first go.

Is this normal?
I had the same on both my 2007 and 2008 HSE. They both needed a nudge in Auto. And they never wiped randomly.
 
1 - 8 of 8 Posts
Top