RangeRovers.net Forum banner

1 - 9 of 9 Posts

·
Registered
2006-2009 Range Rover Sport
Joined
·
31 Posts
Discussion Starter #1
For a couple weeks now my radio will play for 3 seconds and then shut off for 3 seconds and it does this forever, it wont stop. I have unhooked the battery multiple times, tried to shut everything down and back on. Nothing works. It looks like it keeps trying to change settings from like radio to satellite, when I go to any setting on the radio it does this.

An ideas? Thanks
 

·
Registered
2010-2012 Range Rover Sport
Joined
·
48 Posts
I had something similar and it was Bluetooth. I had just paired my new iPhone to my RRS and it cause the radio to reboot. I had s funky name on my phone and changed it. Also I paired through media instead of through the phone. I'm not sure which fixed it but it doesn't do it anymore.


Sent from my iPhone using Tapatalk
 

·
LIFETIME CONTRIBUTOR
2006-2009 Range Rover Sport
Joined
·
11,013 Posts
What model / model year? Does it do this on/off cycling regardless of which input, or only radio?

See attached TSB (assuming you own a 2006-2009), your infotainment system may be stuck in an endless reboot cycle and a software update should fix it.
 

Attachments

·
Registered
2006-2009 Range Rover Sport
Joined
·
31 Posts
Discussion Starter #5
Sorry, it is a 2010 RRS Supercharged. Does it regardless of which input I am trying to do. My engine is tuned so I think if I have to do a software update and reflash I will lose my tune. Trying to avoid that but this I getting really annoying. Thank all.
 

·
Administrator
Joined
·
27,818 Posts
A software update on your ICE would have nothing to do with your engine ECU
 

·
Registered
2010-2012 Range Rover Sport
Joined
·
48 Posts
Yes
I paired it through the multimedia side and it works fine. I selected device to car


Sent from my iPhone using Tapatalk
 
1 - 9 of 9 Posts
Top