RangeRovers.net Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,052 Posts
Discussion Starter #1
Not many pictures were taken :doh: as driving was hot and dusty and
a bit challenging sometimes, but it means we have to go back :clap: as a
brilliant holiday was had by all. 35mm pictures not digital, hence the quality.









Low range+ V8+ 40°C ambient temp= huge amount of heat and test of cooling system.
But the car passed. :thumb:
 

·
LEGACY VENDOR
Joined
·
2,491 Posts
Nice pics.
How were the trails? Any closed by law?

BTW i really like your CB antenna setup. Any info on it?
 

·
Registered
Joined
·
457 Posts
Excellent pics, good to hear your cooling system held up as you were having concerns about loss of coolant weren't you? Have you resolved that now?
 

·
Registered
Joined
·
1,052 Posts
Discussion Starter #4
Most of the trails were as pictured, but a few spots were a bit 'hairy'
and needed concentration, which simply added to the experience.

The CB setup is quite simple.
The mount is no.2 on this page. I have then taken the wire (hidden under the trim and carpet) up
into the ashtray. Using an Intek H520 portable plugged into the lighter socket
I have a good CB setup that can be hidden from view when not needed.
I think I posted some pictures on the site a while ago.

Found it here
 

·
Registered
Joined
·
217 Posts
Tried to open pic's, didn't work, any special way to access them?
 

·
Registered
Joined
·
217 Posts
That's better, don't know what you did but now I can see your pic's. :clap: You were right, it looks like you're in the Rocky Mountians.Beautiful pic's, can't imagine a better way to spend my off time, keep'em coming, love looking at other peoples trips. :thumb:
 
1 - 8 of 8 Posts
Top