RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi all
I have the 1999 year 2,5 dse Range rover with automatic gearbox. Recently appeared the gearbox problems.
When the transmission switch is switched to the R (reverse) or P (parking) display shows gearbox fault.
The shifter selector panel didn't show the red lights by the transmission switch on R or P. And the gearbox turn on service mode. :( :( When restart motor I can drive normaly (no strange sounds from gearbox or samething like that) untli i need Reverse or Parking.
I was changing the selctor position swich(looks unwell). by the gerabox. didn't help, no change :(
Any ideas?
It's a electrical or mechanic problem?
Thanks,
Gatis
 

·
Administrator
Joined
·
27,821 Posts
Have you had the fault checked to see what the error actually is?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Yes. Read errors but does not show anything.
replaced the selector swich, gearbox ecu. nothing!!!
The shifter selector panel shows only the D, N, 3rd gear. nothing from P, R, 2nd, 1st ...
gearbox still service mode (very slow start and reverse switches with beats)
 

·
Administrator
Joined
·
27,821 Posts
If I remember right when a transmission fault shows on the display the transmission will default to 3rd gear, thus the slow starts. However it should have an error logged. What diagnostics are you using to read the error code?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
Will not be able to tell exactly what diagnostics they are used.
Today I returned from the service where they did thet, computer things, and work
the service guys said that they cannot help.
As I watched the service computer shows 2end gear error and selector swich error. (but I changed it !!!!)

reading this forum I have read that the RR is sensitive to electrical problems. or should I look for clean earths, or something similar?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
hi!
I returned today from electrician service
they found selector swich cable breakage under the driver chair.
obviously it would have been the case of fault..:)))
 
1 - 6 of 6 Posts
Top