RangeRovers.net Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
226 Posts
Discussion Starter #1
I have a grinding noise for the front of my transmission, I also have vibration starting at about 3000 rpms, these two issues may or may not be unrelated, other than that the transmission and TC seem to function fine. I have searched this site for symptoms and mine seem different from all the other flex plate symptoms. It sounds metallic and mostly occurs at take off or low speeds acceleration. While driving I can hear it through the shifter as if the shifter was a loud speaker for the transmission, I can change and almost eliminate the noise by pushing the shifter from side to side within the drive position. Definitely worse in the winter and when the truck is cold, this morning was very cold and the noise was there as soon as I put the truck in gear without even moving, then in neutral is was gone, then in gear and it was back, also the noise today was cyclical as if whatever was grinding shrank in the cold and only made intermittent contact. Sounds like to me like the pump or drive plate is rubbing against something, but I have no idea.
 

·
Registered
Joined
·
214 Posts
When my flexy plate went the noise was a loud clattering noise and it was there whatever gear the car was in including park and neutral. The car also run extremely roughly. I am not saying that your flexy plate hasnt gone, im`e just saying what mine was like so you can compare the noise and symptoms.
all the best and merry christmas
Mark
 
1 - 2 of 2 Posts
Top