RangeRovers.net Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
236 Posts
Discussion Starter #1
Just had the cluster pixels repaired on both cars. I removed the instrument packs and took them to a guy in Southampton who advertises on ebay. He repaired both while I waited (3 hours!) and charged a £100 each. Very good service I thought and a good job, I can now read all the message centre again. His number is 07934 280510 no connection or relative to me.
Stewart.
 

·
Registered
Joined
·
67 Posts
i have the same issue but cannot find how to remove the cluster i have searched far and wide on here and on the internet. i have removed clusters from pathfinders, camrys etc but cannot figure this range rover out. not seeing the messages is killing me....please help me with details on how to remove the instrument cluster so i can enjoy my rover just like you. i have a 2003 range rover
thanks

olddog
 

·
Registered
Joined
·
99 Posts
Instructions for removing the instrument pack below.



You need to remove the fascia top rail, which necessitates removal of the A post trim and driver and passenger side upper closing panels, vents and finishers.





 

·
Registered
Joined
·
641 Posts
Do you know if the chap repairs the MID unit ( the base stereo which has an LCD display which loses pixels too )
 

·
Registered
Joined
·
236 Posts
Discussion Starter #5
Yes he does about £120.00 I think.

Stewart
 

·
Registered
Joined
·
124 Posts
Anyone have a good lead for someone stateside that fixes Pixels? Mine is not too bad, so debating whether it would be worth the hastle of removing it?

Wonder exactly what is done to repair the pixels and if it is something that I could do - ie is it something simple like a quick spray of electronics contact cleaner?
 

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
422 Posts
I've used VDOrepair.com to fix the pixels in a cluster in a 1998 BMW 7. They offer a lifetime guarantee. They also service RRs. IIRC, it was five or six years ago and all's still well with the pixel. The MID now needs it though, and I may send that in. No connection to VDO, except as a customer.
 

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
422 Posts
I forgot to address the question about cleaners, etc. I and others have tried a variety of fixes, but only having VDOrepair.com or others do the fix has permanently fixed the issues. The original design was flawed.
 

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
422 Posts
I believe RRs had pixel issues during the BMW-ownership days. I think the clusters were made by the same manufacturer. BMWs had the pixel issues in the 5s and 7s (which had commonality of clusters) from 1995 through 01 on the 7s, and I think through 02 at least on the 5s.
 
1 - 11 of 11 Posts
Top