RangeRovers.net Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
hi everyone. my name is charbel and i have this perfect running range rover with 117,000 mies on it. i broke the front driver window on the dunes this past weekend and the rear window also.

so tomorrow i am going to pick up this 1990 range rover for parts so i can fix all mine. my front winshield have crack in it too..

anyway.. this is it.. i love it. i tow cars with it always, i will say 4 cars a week. never fail on me or gave me hard time. i drove it 8 hours trip and towed cars back..

here is some pictures. i live in michigan by the way. so if anyone need any parts i can sell them local from the one i am getting tomorrow. i will post some pics. and i have 2 sets of brand new shcoks and a set of brand new springs.









 

·
Registered
Joined
·
81 Posts
Sweet pics man. Where are the dunes? Silver lake? We go to Imperial dunes all the time and run our cars. FUN!
 

·
Registered
Joined
·
11 Posts
Discussion Starter #6
i did write something. but i hit save insted of post.. now what? i cant find my reply .. weird. :think:
 

·
Registered
Joined
·
11 Posts
Discussion Starter #7
here is some pictures of the range rover parts car that i just got. if you need any parts let me know.









 

·
Registered
Joined
·
11 Posts
Discussion Starter #10
rover4x4 said:
Those seats look like they have been redone, whats wrong with the parts truck?
it havent ran for over 10 years or so. it is actualy nicer then then black one. yes the seats look like they have been redone. the look almost brand new. i put a battery in it and try to start it. it just click .

i am going to try to spin the engine manualy to see if it is running. 170,000 miles on it.
 

·
Registered
1970-1995 Range Rover Classic
Joined
·
76 Posts
yea that white range looks too nice to part out... hopefully you can get her running!

-Christian
 

·
Registered
Joined
·
11 Posts
Discussion Starter #14
nixrrc said:
Are you interested in selling the brushgard and rear light guards, Charbel? I am in Southern California...
i can sell you the front one.. not sure how much shipping. but i can give it to you for $100 plus shipping.. the rear i might be keeping for mine. i am not sure yet,

i just installed a new set of rims and tires. and i put a pushgard on mine also.. looks good . here is some pictures.



 

·
Registered
Joined
·
74 Posts
Nice Rovers, and welcome to the site! did you try replacing the starter on the white one? sounds like that may be the problem. don't give up on that one - i've got one that's over 200k and still running strong.
Zach
 

·
Registered
Joined
·
46 Posts
charbel said:
i just installed a new set of rims and tires. and i put a pushgard on mine also.. looks good . here is some pictures.

Those tires look like they would rub :think: what size are they? Where about in michigan are you from?
 

·
Registered
Joined
·
11 Posts
Discussion Starter #17
i end up parting out the white one. i needed some parts for the black one.. so if anyone needs parts email me

[email protected]

i am in macomb michigan at 26 and romeo. the tires are pretty big. my 19 year old sister wants to drive it in the winter as long as i put a nice sound system in it.. those tires should keep her pretty safe.

they do rub a little on the front when you turn the steering wheel all the way. they touch the controle arms. the back only rub if i put something really heavy in it. like over 500 pound. like an engine and trans or bunch of parts.

120,000 miles on the black one now still runs strong. the oil light blink like 5 times when i first start the rover then it will go away. new oil filter so i have no idea what is it.
 

·
Registered
Joined
·
1,395 Posts
the oil light blink like 5 times when i first start the rover then it will go away. new oil filter so i have no idea what is it
Try doing a search, someone explained that one. I think it was for low oil level but am not 100%.
 
1 - 18 of 18 Posts
Top