RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter #1
hello,
My truck is making a strong smell of petrol after driving it 4 a while,not at idle,rear wheel arch liner was removed and a broken breather pipe thin one was broken.fixed it and i have cleared the fault with a testbook.petrol smell is still present but weaker than b4,put it on the testbook and i got code p1178,i have read it but could not understand it,correction mixture rich something like that.i noticed also that after starting range when it is hot after 1 hour of resting from hot it wouldn't start from the .1st time but the second ,and the cabin was full of petrol smell.i have no leaks,but when i start to smell petrol and i open the fuel cap it's hissing alot and fumes r coming out.
When i check the charcoal canister by removing the tank pipe marked on the canister it smells petrol fumes so vapors r reaching it.how can i test if the purge valve is operating properly?any help gents?
 

·
Premium Member
2010-2012 Range Rover MkIII / L322
Joined
·
4,635 Posts
P1178 AMFR correction at its maximum positive value. Maybe the engine ECU is trying to correct itself because of an airleak. The engine is now running too rich, hence the smell of excessive fuel.

There a a few things to try, if you do a search. It could be a bad MAF, air leak after the MAF or a problem with fuel. If need be, reset the adaptions again on the powertrain ECU and disconnect the MAF for a while and run it. Not ideal on GEMS, but it may give you a different result from the one you are getting at the moment. Then you may be able to find the solution from that.
 

·
Registered
Joined
·
78 Posts
Discussion Starter #3
Rich998a said:
P1178 AMFR correction at its maximum positive value. Maybe the engine ECU is trying to correct itself because of an airleak. The engine is now running too rich, hence the smell of excessive fuel.

There a a few things to try, if you do a search. It could be a bad MAF, air leak after the MAF or a problem with fuel. If need be, reset the adaptions again on the powertrain ECU and disconnect the MAF for a while and run it. Not ideal on GEMS, but it may give you a different result from the one you are getting at the moment. Then you may be able to find the solution from that.
Thanks 4 ur help.how u can test 4 air leaks without touching the air mass?when the engine is runing at idle if u open the oil filler cap nothing happens the idle stay the same no suction felt if u put the cap close 2 the filler is that the way it should be?and the purge valve is ticking upon touch,it should tick when engine's running?u canot smell fuel from the exhaust only from the fuel filler door.idle is excellent,no missfiring no stalling.only not starting when it's hot from the 1st time,no fault present 4 the coolant temp sensor.confused.i don't want 2 remove the air mass 4 test.
 

·
Registered
Joined
·
78 Posts
Discussion Starter #4
updated:
the purge valve is operating normaly,there is suction from the canister,vapors are not reaching properly the canister,which leaves either a collapsed vapor line or the two ways valve behind the wheel liner.i hope it can replaced without removing the fuel tank (the two ways valve).
can this cause the code to appear?or it is not related?
 

·
Registered
Joined
·
3 Posts
bump.
I have a simialr issue. when I open the petrol cap i get a decent outgassing like the tank was pressurised?
 
1 - 6 of 6 Posts
Top