RangeRovers.net Forum banner

1 - 3 of 3 Posts

·
Registered
1995-2002 Range Rover P38A
Joined
·
4 Posts
Discussion Starter #1
Hello all! My p38 that i bought 3 months ago, has now been driven a grand total of 8.2 miles! The current problem is the only issue left with the exception of the 35 MPH EAS fault. I hope someone can help....I just finished installing a new exhaust system. Luckily, there are no leaks on the exhaust itself, but the is a misfire/popcorn popping noise coming from right around my intake manifold or the headers. I have cleaned the air filter/box, as well as the MAF. Any suggestions as to what this could be? PS: I put brand new plugs in just before the exhaust swap and they were so carbonated that we had to take each one out and clean them, then reinstall. I'm wondering if my plug wires could be faulty? Is there a way to clean them? Anyone want to buy my Rovie? I'm at my breaking point!!! Thank you, thank you, thank you in advance!!!!
 

·
Administrator
Joined
·
27,834 Posts
Wait until it gets dark in an hour, open the hood with the engine running and see if the ignition leads are arcing. If you see arching then replace the ignition leads. If not you most likely have a cracked exhaust manifold.
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
772 Posts
Take the oil cap off and see if there's any compression, you could have a head gasket failure into the valley.
Otherwise it sounds like either a loose plug, or exhaust manifold gasket has failed
 
1 - 3 of 3 Posts
Top