RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
1995-2002 Range Rover P38A
Joined
·
5 Posts
Discussion Starter #1
I have a 2001 P38A and the secondary air pump stays on long after the engine has been switched off, which causes the battery to drain (duh).

I have removed the SAI pump and the vehicle seems to run fine (we are in FL, so emissions are not checked).

I would like to fix the problem rather than run the engine minus a component, but I do not know where to begin troubleshooting.
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
83 Posts
Check relay 21 in the engine compartment fuse box behind the battery. Sounds like the relay is stuck closed and keeping the SAI motor engaged. Swap it with one of the other relays and see if it that stops it.

Kevin
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
212 Posts
Check relay 21 in the engine compartment fuse box behind the battery. Sounds like the relay is stuck closed and keeping the SAI motor engaged. Swap it with one of the other relays and see if it that stops it.

Kevin
Ditto, but I think it is relay RL-10 per Electrical wiring diagram section A1 page 15.
This is my cheat sheet on relays.

RL-1GreenTycoFront Wiper Control
RL-2YellowTycoIgnition Coil
RL-3YellowTycoSunfroof??
RL-4YellowTycoHeated Front Screen - Right
RL-5YellowTycoHeated Front Screen - Left
RL-6Yellow - bigFordA/C blower Motor - Right
RL-7Yellow - bigFordA/C blower Motor - Left
RL-8GreenTycoFront Wiper Interval
RL-9Yellow Horn
RL-10YellowTyco2ndary Air pump relay
RL-11GreenTycoHead Lamp Wash/Wipe
RL-12YellowTycoFuel Pump
RL-13GreenTycoA/C condenser fan 1
RL-14GreenTycoA/C condenser fan 2
RL-15GreenTycoIgnition
RL-16YellowTycoStarter Motor
RL-17BlackSiemensABS Pump
RL-18YellowTycoA/C control relay
RL-19YellowTycoEngine Main Contorl Relay
RL-20YellowTycoAir Suspension
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
5 Posts
Discussion Starter #4
thanks for the help, guys! That was it (RL-10 … there does not appear to be a RL-21 in the engine bay fuse box)
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
341 Posts
My NAS 02 is doing the same thing. I’ll replace the relay ASAP and I hope that fixes it.
 
1 - 6 of 6 Posts
Top