RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
2013-2015 Range Rover Sport
Joined
·
175 Posts
Discussion Starter #1
Has anyone seen a P0526 code yet. What’s interesting is that it hasn’t triggered a CEL but I found it on a code scan because I’m starting to detected a minor rough idle at start up. It decodes as a Cooling Fan Speed Sensor Circuit that I think is in the fan cutch? Doesn’t sound like a cheap fix.

Any ideas?
 

·
Registered
Joined
·
192 Posts
The fan clutch on my 06 failed after 11 years. The fan w/ clutch ran about $250–if I remember correctly. It is an easy DIY but requires a special wrench to hold the fan while loosening. I still have the wrench if you want to borrow it.
This is all assuming the fan/clutch assembly is the same on your 13’.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2 Posts
Has anyone seen a P0526 code yet. What’s interesting is that it hasn’t triggered a CEL but I found it on a code scan because I’m starting to detected a minor rough idle at start up. It decodes as a Cooling Fan Speed Sensor Circuit that I think is in the fan cutch? Doesn’t sound like a cheap fix.

Any ideas?
Were you able to fix this problem, had to replace the fun clutch?
 

·
Registered
2013-2015 Range Rover Sport
Joined
·
175 Posts
Discussion Starter #4
Were you able to fix this problem, had to replace the fun clutch?
Yep, ended up replacing the fan and clutch as one piece. Cleared the codes and they never came back.
 

·
Registered
Joined
·
2 Posts
Thanks for your reply, seems I’ll need to get it, still not showed up any problem with the engine temperature but also I got the Pcode by scanning the vehicle...
 
1 - 5 of 5 Posts
Top