RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
806 Posts
Discussion Starter #1
"Catalyst System Efficiency Below Threshold (Bank 2)"
Hello,
I have cleared this code twice, but it came back again today.
Has anyone any experience with this?
TIA
 

·
Registered
Joined
·
480 Posts
Run a search (a really great search engine which does not track you is https://duckduckgo.com/) Lots of info, most for mechs replacing catalytic converters. But you might try some other things first. I got P0430 for the second time in six months this morning. Reset it and added half a bottle of Gumouts best intake cleaner. Worked six months ago. Here in the States we have laws that require the converter to last at 80K or 8 years.
 

·
Registered
Joined
·
806 Posts
Discussion Starter #3
Run a search (a really great search engine which does not track you is https://duckduckgo.com/) Lots of info, most for mechs replacing catalytic converters. But you might try some other things first. I got P0430 for the second time in six months this morning. Reset it and added half a bottle of Gumouts best intake cleaner. Worked six months ago. Here in the States we have laws that require the converter to last at 80K or 8 years.
Well, the code returns, goes off by itself and returned again. I tried Cataclean, and another FI cleaner, all to no avail. Yesterday I took it into the dealer and asked about the Cat warranty and indeed here in Canada it is 8 years or 120,000 Kms. They checked my car for other codes, etc., and decided that the cat needed replacement which they will do under warranty.
The Service rep told me that they had never had this code on a RRS, and only twice on the full size LR.
They ordered the part and will do the work next week.
I will post the final outcome and also if the code returns.
PS; since it is now cold in my neck of the woods, the first start of the day has died almost immediately. I pointed this out to the rep and he said that that is caused by the throttle body, but there are no codes being thrown.
 

·
Registered
Joined
·
480 Posts
Still think you have dirty injectors. I got P0430 for the third time in 12months a week ago. Reset it and added half a bottle of Gumouts best intake cleaner. Worked six months ago. BUT, IF YOU GET A NEW CAT, GOOD. SOUNDS LIKE YOU HAVE A GREAT DEALER.
 

·
Registered
Joined
·
806 Posts
Discussion Starter #5
Still think you have dirty injectors. I got P0430 for the third time in 12months a week ago. Reset it and added half a bottle of Gumouts best intake cleaner. Worked six months ago. BUT, IF YOU GET A NEW CAT, GOOD. SOUNDS LIKE YOU HAVE A GREAT DEALER.
I bought the truck from a Generic used car dealer. This is a Land Rover dealer that happens to be close to me.
 
1 - 6 of 6 Posts
Top