Range Rovers Forum banner
1 - 3 of 3 Posts

· Registered
2006 l322 Westminster #41
Joined
·
1,941 Posts
I had mine in and out while doing the trans cooler. Recommend that you get the dow corning silicone grease for the o rings in the pipes. Things might be a little stiff on disassembly so you may have to work the fittings a bit to loosen the crud. On reassembly check that the appropriate hoses are properly clipped into the rad shroud. The main crank pulley was a week away from cutting thru a hose that was not clipped in by someone who changed the rad before we got our 04.
 

· Registered
2006 l322 Westminster #41
Joined
·
1,941 Posts
Let us know if that stops thd code. I have read that if will but it could also be the temp sensor at the tstat. Or lower rad hose. I have done the lower rad hose one but not the others. I have a lower temp tstat in there but no issues for s year and now if comes up. As a point of interest if I do not clear the 0128 code it puts up iirc the po171 and 174 codes after a few more cycles. It does show how interconnected the sensors are so little is as obvious as it seems.
 

· Registered
2006 l322 Westminster #41
Joined
·
1,941 Posts
Finally got around to replacing the temp sensor near the engine thermostat on our 04 and also changed the trans cooler stat which I had read can cause the P0128. Over last few days the 128 code has not come up but recently got P1172 and P1175. I did change one 02 sensor pre cat so will see what gives now. I did notice a bit of looseness at the throttle body air inlet clamp which I had removed to change the temp sensor so will see if there is any chance it will solve the running rich scenario of 1172 (both banks)
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top