RangeRovers.net Forum banner

141 - 148 of 148 Posts

·
Registered
Joined
·
24 Posts
Let us know how the install goes... I have been following that thread as well. It seems like the Merryway may be a more involved install than the NaviPlus.

Are you going to install it yourself or have some auto audio/video shop do it?

Thanks.
Will do. I’ll be installing myself. Will likely be this weekend.

Thanks, W84IT... my unit arrived today and all looks good. Thanks for the quick shipment.
 

·
Registered
Joined
·
558 Posts
You're welcome. Be sure to call or text me when you have it installed. It can be a little tricky to get it all set up. There are some hidden menus that you might need to access to change some settings. The powerfulUK guys speak about this in one of their videos...

 

·
Registered
Joined
·
1 Posts
resurrecting this thread rather than starting a new one. Just had Signature Audio in Scottsdale install the NaviPlus Apple CarPlay modules that I bought some time ago. Was waiting to see if RR could solve the native system connection issues, which were not resolved to my satisfaction. A couple of initial observations. Installers had some initial issues with dip switch positions needed to be used. After a bit of down time waiting for the sun to come up down under the Aussie developers were right on the spot helping solve the issue. Many thanks to them. System now seems seamless, though on first impression the screen resolution is not crisp.

System seems to work great. Waze was running in the background when I left the shop and warned of a red light camera upcoming. There is a bit of flickering on the waze screen, will see about that. Bottom line right now is this is working just like some rental cars I have had recently with CarPlay. Just hook it up and go. The navigation button on the dash now brings up the CarPlay screen with a soft button on the bottom left accessing the apps. First day, but pretty happy so far. Will post some updates after I have lived with it for a while. The install shop has been looking for system like this that integrates into the basic vehicle system. They said this one looks as good as any aftermarket they have found, at least for Rover.
@DieselD, I'm in Scottsdale and have a '16 as well. Can u share what you paid Signature for the install? Interested in doing the same.
 

·
Registered
Joined
·
558 Posts
Ray is awesome.

I installed it in about 3 hours with lots of little breaks to keep my dogs happy.

installed in a 2016 Sport

View attachment 281240
I just did an install in a 2015 L494 today and the owner was very pleased. He drove all the way from San Diego to get this unit installed. I asked him to register on this forum and post a review so hopefully you guys will see that soon.
 

·
Registered
Joined
·
106 Posts
@DieselD, I'm in Scottsdale and have a '16 as well. Can u share what you paid Signature for the install? Interested in doing the same.
memory serves, it was $750 or so. I am thinking it might be less since they have experimented on my car. Talk with Sean. They also did a killer audio upgrade using Audison amp. Love it. Tell them David sent you
 

·
Registered
Joined
·
106 Posts
Ray is awesome.

I installed it in about 3 hours with lots of little breaks to keep my dogs happy.

installed in a 2016 Sport

Could you tell me the nav program in the photo? I am using Waze and it not quite as crisp as this pic

View attachment 281240
 

·
Registered
Joined
·
558 Posts
memory serves, it was $750 or so. I am thinking it might be less since they have experimented on my car. Talk with Sean. They also did a killer audio upgrade using Audison amp. Love it. Tell them David sent you
If you're located in Southern Cali, I can install the Android unit for an additional $300 if you're willing to bring your vehicle to me.
 
141 - 148 of 148 Posts
Top