RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1
G'day,

My 3.5 uses so little engine oil between services (I do it every 5,000 k's) that I never really bother checking its level on a weekly basic ! :)

However, even since I've owned the 3.9 (10 years +), it regularly consumes more oil than I'm comfortable owning up to..... :shock:

I spoke to my mechanic about this and he confirmed that the average 3.9 is an oil burner !!!

So my question - is this the norm from an average owners perspective ???????? Fouled plugs are a pain !

Looking for feedback...

Thanks
Rod
 

·
Registered
Joined
·
1,395 Posts
My 3.9 has done over 250,000km, uses nearly none. I suspect what it does use leaks out to rust proof the chassis.
 

·
Registered
Joined
·
49 Posts
Discussion Starter #3
Thanks for your feedback rufant.

Come-on guys, any more feedback ?

Cheers
Rod
 

·
Premium Member
Joined
·
1,703 Posts
my 94 3.9 uses about a litre per 5,000k's, its 230,000k old and I have only had it since 180,000. But most of that oil is from soaked oil cooler lines I should replace one day. It did use more oil when I first got it, putting it on gas seems to have stopped a bit of consumption. I have been told by several poeople the lpg doesn't take the glaze off the rings like petrol and can prolong of improve the condition of rings and thus lower oil use, but sounds like hogwash to me.

my 94 4.6 uses about the same, but the bloody rocker covers come loose on it even after thread locking the bolts, spews oil everywhere.
 

·
Registered
Joined
·
665 Posts
do the steam sleaning trick, if your rings are starting to stick, it could be a reason. also run some ATF before your next oil change then try again. should revive your engiine.

also, being an old engine, i might run thicker oil then the manufacturer suggested for new. not by much but 10points, even a 15w40
 
1 - 5 of 5 Posts
Top