RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
The rear center brake light will flash intermittently even with the key out of the ignition, in addition the rear wiper will randomly run as well, again even with key out. If I turn the rear wiper on and off a couple times it fixes the problem, though if I pull the battery and reconnect it will always start again... Any ideas?

On a side note, the CEL and ABS light are both on as well, when I hook up a code reader it says there are no codes, yet the CEL remains on... Do RR take a special OBD II code reader?
 

·
Registered
Joined
·
701 Posts
I might suspect a BECM issue, but I would start with the less expensive stuff. The wiper is probably just the wiper handle. I've noticed that with mine, if I move it forward and then back with the vehicle off. It will actually turn on the next time I start the vehicle, but only cycle once. A malfunctioning switch in the handle could be causing this. The brake light, I honestly don't have a clue if its doing it while the vehicle is off. The ABS light will be on until you go about 5mph, then it will extinguish. That is normal operation, if it stays on, then you have an issue. You should just be able to pull codes from the vehicle using a standard OBD II scanner. How is your battery and alternator, these two items can cause some very awkward issues if not functioning properly.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #3
battery is new, alternator not sure of as i only go the truck running last night for the first time in 6 months...
 

·
Registered
Joined
·
23 Posts
Discussion Starter #5
I would but its a brand new battery and it is not running so cant perform the other tests.... voltage is currently a little low due to all the starting attempts... but problem was present even when batt was brand new
 

·
Registered
Joined
·
401 Posts
have a look at your fuse box under the hood. Mine got real wet once, similar symptoms.
 
1 - 6 of 6 Posts
Top