Range Rovers Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
Hey folks,
I had a previous thread, which I concluded problem fixed after several visits to the service center;
However, recently after another rain, the below errors started arising again.
I know the post is long; but please bear with me :( OTL

1) Active Safety belts fault
2) Suspension fault detected
3) Blind Spot Monitoring system fault detected
4) Cruise Control unavailable
5) Tire pressure monitoring fault detected
6) Lane Keep Assist unavailable
7) Hill Decent Control unavailable
8) Power Steering Assist decreased
9) ABS / IEB unavailable

This occurs at a specific situation; when driving in the rain and the above error starts popping up a day or two later.
Error messages do not pop up when driving in the rain, only a day or two later.

that being said,
I got my hands on the obd2 error codes from the service center (they use pathfinder whatever..)
bear in mind I am translating Korean to English so my choice of words may not be ideal.

1) Anti-lock breaking system control module [ABS]
- U0075-88 : control module communication bus 'C' not connected[U0075] - Bus not connected
- C0506-14 : Front right wheel speed sensor - break - grounding wire break or short
- U0046-87 : Vehicle communication bus C - message omitted

2) All terrain control module [ATCM]
  • U0046-87 : Vehicle communication bus C - message omitted
  • U0046-88 : Vehicle communication bus C - bus not connected

3) Body control module [BCM]
  • B100D-82 : Column lock device authorization - active/sequence counter inaccurate/not updated
  • B100D-87 : Column lock device authorization - message omitted
  • U0515-62 : incorrect data received from remote function activation - signal comparison failure

4) Cruise Control Module [CCM]
  • U0046-81 : Vehicle communication bus C - incorrect serial data received
  • U0046-87 : Vehicle communication bus C - message omitted
  • U0046-88 : Vehicle communication bus C - bus not connected
  • U3000-53 : Control Module - deactivated
  • U1A00-82 : Private bus circuit - active/sequence counter inaccurate/not updated

5) Chassis Control Module [CHCM]
  • U0046-81 : Vehicle communication bus C - incorrect serial data received
  • U0046-82 : Vehicle communication bus C - active/sequence counter inaccurate/not updated
  • U0046-87 : Vehicle communication bus C - message omitted
  • U0046-88 : Vehicle communication bus C - bus not connected

6) Gateway Module 'A' [GWM]
  • U0046-87 : Vehicle communication bus C - message omitted
  • U0046-88 : Vehicle communication bus C - bus not connected

7) Headlamp Control Module 'A' [HCM]
  • U0046-81 : Vehicle communication bus C - incorrect serial data received
  • U0046-87 : Vehicle communication bus C - message omitted
  • U0046-88 : Vehicle communication bus C - bus not connected

8) Headlamp Control Module 'B' [HCM]
  • U0046-81 : Vehicle communication bus C - incorrect serial data received
  • U0046-87 : Vehicle communication bus C - message omitted
  • U0046-88 : Vehicle communication bus C - bus not connected

.... and so on and so forth
(there are a total of 21 module errors listed. but 15 of them have U0046-87 & 88 error codes only)

As some of you might have noticed, modules with U codes does not seem to be the source of the problem;
instead I am more focused on - C0506-14 : Front right wheel speed sensor - break - grounding wire break or short.

I think the answer lies within that specific code as a faulty wheel speed sensor or wiring seems to coincide with the problem; though i may be wrong or biased.
what troubles me the most is that the service center & several private local mechanics that i have been to all say that the wheel speed sensor seems visually fine.

Any ideas will be appreciated.
 

·
Registered
2019 Range Rover Sport SCV8 ATB (L494)
Joined
·
266 Posts
Check the battery ground cable for loose connection or corrosion. Can lead to multiple faults like that.
 
1 - 4 of 4 Posts
Top