Range Rovers Forum banner
1 - 20 of 34 Posts

·
Registered
Joined
·
24 Posts
hi just bought meself a p38 2.5 dse and the radio bad so I decided to change it. first thing was no constant 12v feed. then I found a broken off wire (purple) tested it with my multi meter and sure enough there was 12v so I wired up the new radio and ive lost all instruments. I checked the fuses in the seats and they is all fine but I did notice that one of the fog /driving light switches are lit up? so I looked round the outside of the car and no lights are on? some one previous had bodged the wiring up and ive no idea what colours are what. any help would be great
 

·
RIP Our Friend
Joined
·
27,834 Posts
FAQ stickie above #1...

First item listed is RAVE which has diagrams and almsot everything you would ever need to work on your own rig.
 

·
LEGACY VENDOR
1995-2002 Range Rover P38A
Joined
·
4,229 Posts
Where in Somerset are you based?
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #6 ·
burnham on sea. ive been looking at the electrical side an ive found that the large brown wires that connect to the fuse box under the seat have no power. so I tested the brown cables under the fuse box in the engine compartment and they have power. now im confused
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #7 ·
I have power in the fuse box now. but I still have no instruments and I don't know where the earth wire is for it? fuses 1 and 8 both have 12v but when I test the purple wire (radio 12v constant) there is less than 1v
 

·
RIP Our Friend
Joined
·
27,834 Posts
Seriously dude, download RAVE. All grounds are photographed, diagrammed and handed to you in the ETM.
 

·
RIP Our Friend
Joined
·
27,834 Posts
I just downloaded it here at work with no issues. File unzipz jsut fine and the RAVE is operational.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #15 ·
looks like I need my becm repaired. it controls the power to the radio and instruments. might shove 12v down purple wire and see what happens
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #16 ·
'BIY' bodge it yourself lol I cut the purple wire if the rear connector on the BECM then took a feed from the number one fuse and bingo everything works again its a Proper Job (in a somerset accent)
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #20 ·
the fuse box in engine bay smells burnt. but ive checked all fuses and they have 12v? (under the seat and engine bay)
 
1 - 20 of 34 Posts
Top