RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
538 Posts
Discussion Starter #1
Right hello people. Done the search bit, but can not find what i need.
Today after not using the RR for a couple of weeks, it has started making some very odd noises.
Seems to be under the car, a load cracking noise, not all the time, just now and again. Bit like driving over a loose man hole cover. metal on metal however at other times it sounds like a rattling cat.
Can't pin it down, jacked up all round can not play in wheel bearing or props, though not removed them yet.
would have thought that if it was transfer chain it would be all the time. not coming and going, power or coasting does not seem to make much difference either.
So pointers please or its back to the Freelander!!
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
148 Posts
I had one of the cats on mine doing the same thing, wouldn't do it all the time but it definately did it. I've heard of fixes being to screw a long Tek screw into it, but at best it would be a temporary fix.. Maybe the flex plate is on the way out. The noise from that maybe intermitent until it failed completely.

Oh and it's the weekend, people might have better things to do than sit around on rangerover.net answering peoples question. Give them a little more time. Lots of timezones for people to contend with on this forum too. It's early morning in the States as I type this, around 5am on their time.
 

·
Registered
Joined
·
538 Posts
Discussion Starter #4
Don't mind me, just crabby, anyway found the hassle i think, front prop uj, next to the transfer box.
So removed it for now. another job to do!
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
148 Posts
I hear you. My day started off great watching the Red Bull Air race then deteriorated rapidly after that. Glad to hear it will be a relatively easy and quick fix. :D
 
1 - 5 of 5 Posts
Top