RangeRovers.net Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1 (Edited)
Hi everyone,

I’ve recently started hearing this noise exactly 3-4 secs after my 17 SVR has been turned off. It has nothing to do with access mode or the suspension. The noise is coming from somewhere in the engine bay. It sounds similar to the hood latch opening or when you electronically open/close a latch. I’m stumped as to what it could be.

Low battery “please start engine” Has started to pop up intermittently but not sure how this noise would be linked to that.


Any ideas?




Thanks
 

·
Registered
Joined
·
26 Posts
Well, I’m not sure, so here’s a wild guess. It sounds like the mechanical noise from a solenoid changing state. If that was an old Diesel engine I’d swear it was the fuel cut off solenoid. They move via battery power so perhaps a low battery condition is causing it to trigger more slowly.

Someone more knowledgeable than me will likely have a better answer.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #3 (Edited)
Thanks for response. I’ll purchase a trickle charger and see how things go otherwise to the dealer it goes
 

·
Registered
Joined
·
238 Posts
It does sound like a solenoid. Curious to what that is. Have you lifted it to offload position then went under it to see if its louder under there?
 

·
Registered
Joined
·
30 Posts
Discussion Starter #5
I haven’t at this point. You don’t notice the noise from inside the cabin at all, a lot quieter with the hood down and significantly louder with the hood open. Also appears to make that noise when you cycle the keyless button on/off without starting it.

I just purchased a trickle charger and will leave it on for 24 hours to see if a full battery makes any sort of difference.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #6 (Edited)
After going back out there and taking the engine cover off. It appears to be coming from the top. I can feel something within the piece I’m touching when you hear this sound. I’m not sure if it’s this part itself or something right below it, however that is the area the noise is generating from. It seems like whatever is making the noise clicks right before start up as well.

 

·
Registered
Joined
·
238 Posts
After going back out there and taking the engine cover off. It appears to be coming from the top. I can feel something within the piece I’m touching when you hear this sound. I’m not sure if it’s this part itself or something right below it, however that is the area the noise is generating from. It seems like whatever is making the noise clicks right before start up as well.

Is there anything plugged into that part? If so maybe unplug it and see if it still does it. Sound so much like a solenoid. Is this part of the intake system?
 

·
Registered
Joined
·
30 Posts
Discussion Starter #8
I didn’t notice anything plugged in. I have now also charged my battery completely with no change.

With the lack of response to this thread I’m guessing this noise is not normal or common. I’ll reach out to my SA in the next few days and make a time to take it in.
 
1 - 8 of 8 Posts
Top