RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
2016-2018 Range Rover Sport
Joined
·
38 Posts
Discussion Starter #1
I recently purchased a 2018 RR Sport HSE Dynamic and am having issues using my iPhone X. Specifically when using Google Maps on my iPhone I no longer get volume/sound from my iPhone. The phone pairs fine with the RR and phone calls operate fine through the touchscreen and car speakers. I also do not get audible incoming text notifications on my iPhone as I did previously in my 2011 RRSSC.

I figure i've overlooked some setting somewhere? Can someone point me in the right direction? I've tried searching the forum threads but could not find anything.

Thanks
 

·
Administrator
Joined
·
27,819 Posts
iPhone has never been reliable with with the two new generation models. Fortunately you can not blame LR for this one. There have been several iOS updates that have solved various issues with the new generation. It is iOS that is to blame for iPhone X issues with LR products. Other iPhones have no real problems if kept up to date. As has been pointed out in other iPhone X threads, make sure you are on the latest update. Of course in your instance you have Google to deal with.
 

·
Registered
2013-2015 Range Rover Sport
Joined
·
238 Posts
Go to Google Maps --> Settings --> Navigation
If you want navigation prompts over the RRS speakers, choose "Play as Bluetooth Phone Call".
If you want the prompts on the phone, turn both options off.
The standard "Play over Bluetooth" setting doesn't seem to work when connected in the car.


Sent from my iPhone using Tapatalk
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
38 Posts
Discussion Starter #4
Go to Google Maps --> Settings --> Navigation
If you want navigation prompts over the RRS speakers, choose "Play as Bluetooth Phone Call".
If you want the prompts on the phone, turn both options off.
The standard "Play over Bluetooth" setting doesn't seem to work when connected in the car.
/QUOTE]

Thank you. I will change my iPhone settings for Google Maps (didn't even know of those preferences) and report back with outcome.
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
38 Posts
Discussion Starter #5
Go to Google Maps --> Settings --> Navigation
If you want navigation prompts over the RRS speakers, choose "Play as Bluetooth Phone Call".
If you want the prompts on the phone, turn both options off.
The standard "Play over Bluetooth" setting doesn't seem to work when connected in the car.
/QUOTE]


Thank you. I will change my iPhone settings for Google Maps (didn't even know of those preferences) and report back with outcome.
Sorry for the delayed follow up but as "Booyah" instructed I made the preference changes on my iPhone and it worked.
 
1 - 5 of 5 Posts
Top