RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1 (Edited)
Hi all bypassed Nokia module worked for a for a few days but now not working went off once now gone off altogether checked fibre optic but no red light running through it scratching my head now
 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
162 Posts
That’s not good - did you bypass it with a biro pen tube? If so and if still in place something else is likely dead in the circuit. Maybe the rse or the tv module? You had better pray to the bank of god it’s not the amp as they aren’t cheap. Start pulling out the most plugs until you see the red light and follow from there. If you have another failure my guess is you have a water leak destroying that rear cubby like I did - blocked sunroof drains!
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
That’s not good - did you bypass it with a biro pen tube? If so and if still in place something else is likely dead in the circuit. Maybe the rse or the tv module? You had better pray to the bank of god it’s not the amp as they aren’t cheap. Start pulling out the most plugs until you see the red light and follow from there. If you have another failure my guess is you have a water leak destroying that rear cubby like I did - blocked sunroof drains!
That’s not good - did you bypass it with a biro pen tube? If so and if still in place something else is likely dead in the circuit. Maybe the rse or the tv module? You had better pray to the bank of god it’s not the amp as they aren’t cheap. Start pulling out the most plugs until you see the red light and follow from there. If you have another failure my guess is you have a water leak destroying that rear cubby like I did - blocked sunroof drains!
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4
Yes done the biro bit worked fine for a couple of days then went off and came on now back to orange light flashing tried the reset on screen for 5 seconds screen came on but screen not reacting to touch
 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
162 Posts
In that case I thing you need to go in the rear cubby and start pulling most leads until you see the light
 
1 - 5 of 5 Posts
Top