RangeRovers.net Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have an 88 RR clasic over the last week it has been loosing more and more power, now it will just idle and when you put in in gear and step on the gas, it sputters, will hardley move. Over the last 8 months i have replaced the alternator, fuel pump ( 6 months old) and sounds good/filter( about 1 year ), plugs, wires, cap/rotor, air bypass valve and have a new throttle potentiometer on the way ( not sure if that will help) but it is old so why not. working my way through the manual, can anyone help please.
 

·
Registered
Joined
·
13 Posts
Sounds like the exact same issue I am having. I can start it, it will idle fine, and when I try to accelerate, it will not want to get over 1500 RPM's.

I have researched here and tried all that have helped others, but now I am at a crossroads...
 

·
Registered
Joined
·
13 Posts
People talk about the fuel filter, fuel pump, coolant temp sensor, stepper motor, TPS, and ignition coil...

I have done filter, pump, plugs, cap, rotor, wires, stepper motor (idle air bypass), coolant temp sensor, and still no change.

I dont know what the pressure regulator would do...my 88 does not have an electrical regulator, rather a vacuum driven. I do know others also mention leaking injectors.
 

·
Registered
Joined
·
10 Posts
I've had the same problem on my 91 classic and after looking at random parts and doing tests on fuel pressure and replacing different things...........it ended up being the liner in the air filter tube that connects to the throttle body being ripped and kept getting sucked in when you push the gas pedal. That inturn blocked the air getting into the mass air flow sensor and the throttle body.
 

·
Registered
Joined
·
43 Posts
Look at the plugs. They will tell you whats happening. Ok lets do a test. Everybody pull their plugs and take a picture, post it as a reply or describe them if you have these problems. They will tell you if its air, spark, timing, or fuel. There's no sense in throwing parts at a Range Rover. It could be a combination of failures or adjustments or both who knows on old brittish trucks! Correct diagnosis is the solution and it starts with the plugs, at least when it starts at all! :lol:
 

·
Registered
Joined
·
45 Posts
MIne just started doing this...
its very sluggish, and the cats started rattling at the same time this started happening... so I think it's a blocked cat like others have suggested...
Im going to replace mine, ill let you guys know.
 
1 - 11 of 11 Posts
Top