RangeRovers.net Forum banner

1 - 4 of 4 Posts
G

·
Guest
Joined
·
0 Posts
Discussion Starter #1
New to Land Rover, lurking the site for a few months now. 1st service experience, wanted to share story & get input on whether or not this is par for the course. Purchased 06 RR Sport 4 weeks ago, 25k miles, 1 owner. After longer commutes, I noticed a drivetrain noise on the freeway after letting up on gas pedal – a bit of a binding or grinding noise. I only hear it if going over 30mph and letting up on the pedal “coasting”. I took it to dealer & after 1st day inspection was informed it was the front diff. They would have to submit the repair request to LR and get approval for the part and service repair. Day2 got approval, day3 part arrived. I’m at day 5 now & still no truck. It’s quoted as a 5hr job. After speaking with SA in person tonight, the delay just didn’t add up. He said they are “having difficulty getting it back together, and “some repairs take longer than expected”. I assumed they were working on other cars as mine sat. I then spoke to a Service Manager & asked for details on what the difficulty was in getting the truck back together. He spoke with the tech & said the driveline “came apart” when “reattaching to the front diff”. And that, I “might need a new driveline”. Does this sound normal or is the driveline comment an excuse to buy more time with working on the truck and getting it back together?
 

·
Premium Member
2006-2009 Range Rover Sport
Joined
·
5,175 Posts
Tough to make a call on this unless you're right there in the shop. Just be grateful its on their dime!!
 

·
Premium Member
2006-2009 Range Rover Sport
Joined
·
1,147 Posts
i was told the exact same thing with my MY06 HSE. i'd have to look it up when it happened, but IIRC the front diff was leaking and had to be replaced. they practically told me the exact same thing about the driveline coming apart. they didn't necessarily say it happened when reattaching the front diff, but an indy shop here said it's likely what happened. i think someone else (not someone from the indy shop) noted it likely happened due to mechanic error. only difference with my story is that it only took an extra 2 days. one day to get the part and another day to put it all back together.
 
1 - 4 of 4 Posts
Top