Range Rovers Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Hey guys, just wanted to make an introduction here before I start having to come for help .. (nothing major yet, knock on wood). I purchased a '99 Callaway 4.6 HSE #205 in Epsom green about a month ago with just shy of 60,000 on the clock. My dad and I have just gotten it inspected with no problems. The SRS light was on when purchased and that was fixed. The only current annoyances are the drivers side headrest is stuck in its position (I read a post on here and tearing the seat apart to put a new track in probably won't be occurring..) and we think the sensor for the climate control is bad- usually for the first few minutes the system is on it says the external temp is 32 and wont blow cold air until it reaches a more accurate temperature. The fan speed knob doesn't function and the LED for temperature readout is extremely dim, so we might replace that unit. In the meantime, just setting both driver/pass temperatures up a few degrees will considerably lower the fan speed and still blow cold air (or vice versa for warm air).

Also, is there a specific forum to post pictures or can they be fine in any message? Thanks!
 

·
Registered
Joined
·
120 Posts
That external temp problrm is not always the external temp sensor.
Had same problem, replaced sensor, no change. Replaced Hevac head unit for other reason and hey presto external temp bang on. :dance:
 

·
Registered
Joined
·
407 Posts
PICTURES!!!!!!!!!!!!!!!!!!!!! :pray:
 
1 - 4 of 4 Posts
Top