RangeRovers.net Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
So “some” idiot cut the wire harness on my truck years ago and lost the harness and I’m having difficulty finding resources on the colors and how they match to a modern stereo head unit. I’ll post some pics of what I’m working with and if anyone has any info I would be super grateful! I currently don’t have a test light so just messing around should have one in the mail in a couple
Of days.
. Don’t really need the photo of the old radio wires I guess.
. Thanks in advance I’m sure I’ll probably need s test light cuz there are a couple that are the same color (black). 87 Classic
 

·
Registered
Joined
·
1,413 Posts
darn you have an 87, I don't think an installer would have a record. your best option may be the RAVE, next best is to use a 9v battery to a suspected wire set and as you touch the battery poles the speaker makes noise, this helps you id wire to speaker location.
normally the black wire is negative and the black with white stripe is positive for a speaker. purple is normally dash lighting if your radio supports it or could be antenna amplifier, brown is memory or constant power, and red would have been key controlled power.
ground was normally a thicker gauge screwed to the body.

I may be wrong so double check your wire action.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
Thanks for the response! yeah I’ll give the rave a look. I need to take a better pic of the cut wires. By dash illumination do you mean just the radio lighting up or the radio dimming with the dash lights? I could seriously slap my younger self if I could for all the stupid things I did to the my poor truck.
 

·
Registered
Joined
·
1,413 Posts
well, some aftermarket radios try to emulate many factory features, one of them is the key and screen illuminate as the lights are turned on. this is were the purple wire may come into play. yes it is called dimmer feature.
 

·
Registered
Joined
·
330 Posts
Have you looked at the wiring diagram in the WSM? I'm horrible at reading them but it might help you.
Crutchfield has very helpful customer service maybe they can assist.

If you have no luck with any of the above suggestions.... I can pull mine & snap some pics. Though I suspect it is hacked up too. lol
 

·
Registered
Joined
·
14 Posts
As 95 said about using a 9volt battery, you can also see that the speaker will move in or out as you do this. You need the speaker to move out for the correct polarity. I just had to do this with with a very badly damaged ads system. Good luck
 

·
Registered
Joined
·
10 Posts
Discussion Starter #7
Thanks for the response! I was able to figure it all out I think!? I have music now at least! I matched up the speaker wires using a 9 volt battery and then the remaining ones using the rave as a guide. Seem to be a few wires that don’t have a corresponding partners but everything seems to be ok as far as I can tell? I’ll post all the pics of the rave that I used just in case anyone needs to look at it all in the future.

The red and black wire “warning light” nowhere to connect, white orange ignition aux, purple black ignition on, black ground. On the stereo side there was a blue wire for illumination no wire to connect to and a antenna amplifier no corresponding wire. ¯\_(ツ)_/¯ someone who is smarter than me please correct me if they think I screwed something up, I am horrible at reading wiring diagrams. Seems to work ok though! Thanks for the help! Sorry for the long post!
 
1 - 7 of 7 Posts
Top