RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #1
IJust changed the control panel with a brand new one and it works great with no book symbol! Next I had the blower motors changed with new ones since they were blown and Air has been recharged when I picked it up the book symbol was up don't know why!Motors and Air work greatno problems on that end. Don't understand why after the control panel was changed it was fine no book symbol but as soon as the motors were changed and the freon charged BOOM there it is. From the looks of it and the way it runs doesn't seem to be a problem.Do I have to reset something or have a code cleared? I'm just a little worried any help would be much appreciated. Thanks Warren
 

·
Registered
Joined
·
1,052 Posts
HVAC is self diagnosing. If there is no fault= no symbol, and symbol= fault.
This happens every time the ignition is switched on, but the fault codes are stored in the
memory. Best thing to do is to read the fault codes to give you an indication as to what
is wrong.
 

·
Registered
Joined
·
48 Posts
I currently have one that shows a book symbol. The condenser had corroded badly and was replaced along with some relays. Now the computer does not have any fault codes but the HVAC screen still shows a book symbol. My mechanic has had the car hooked up twice and still dosen't see any codes.
Have searched around on here but had deceided to just ignore it. Unless someone can shed some light on the issue?
Aynsley
 

·
Registered
Joined
·
541 Posts
My HVAC works perfectly fine. I have the book symbol 90% of the time. I don't really care, if it works, it works, to hell with that stupid thing.
 

·
Registered
Joined
·
538 Posts
Hi, had the book with mine, turned out to be the little fan under the clock that checks the cabin temp. This had stopped turning.
The Hevac then does not know what the inside is doing.
 

·
Registered
Joined
·
59 Posts
Discussion Starter #6
How about if I unhook the control panel then reconnect it since when I first connected it no book symbol but new motors and air recharge there it is! Maybe another issue?
 
1 - 6 of 6 Posts
Top