RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
New ‘18 RRS HSE V6 SC less than 150mi three issues

Picked up the new 18 RRS HSE V6 SC, all options except Dynamic and Towing this past Saturday. I ended up trading in my 14 RRS V8 SC with Dynamic and all options.

I drove the new RRS for 150 miles, great car, drives much better, new LED lighting is bright, dual screens are good, not great... they clearly had three different programming teams work on the center stack and individual dual screens.

Small example, all settings should be able to be accessed through the vehicle settings page within the dual screens. No you have to use the menu button on the left side of the wheel... another example, use the screen black out button function for the dual screens... doesn’t black out the lower screen. You have to manually close the lower screen and still have it back lite.

I know, these are real First World kind of problems... not the end of the World.

Now there are a few issues I’ve discovered that speak to quality and there is a lot that I like about the new car. I don’t want my old car back, I just want the new one, I just purchased to not have issues on my first day of ownership.

Let me know if you are seeing the following type issues...

Center dash cup holder lid cover does not retract all the way under the dash so you have access to both cup holders. It stops at about 98 percent of being open... probably can live with it, just a small detail.

The bigger issue is that the cup holder plastic tray slides forward - like it should when you actually want to access the storage area under the cup holders... problem is that it moves on its own when you brake and have a cup or any weight like a cell phone in the cup holders.. it doesn’t stay put. Strange...

Most annoying issue is that when talking hands free on a cell phone call, constant cracking and popping during phone calls. Not limited to cell calls, all radio sources also have cracking and popping sounds - not constant, usually every couple of seconds - not tied to meridian surround sound processor - does it on all processor types... not tied to throttle position and not present when the radio is off. I think it’s either the radio itself or the chassis grounds need to be looked at.

Lastly, notice smell of radiator fluid after driving for a few minutes and cranking the heat up... hopefully an easy fix.

Dealership can’t get me in with a loaner until the end of the month... I told them I’ll take my old car back as a loaner... they have it in their lot.

Other than the above a great car...
 

Attachments

·
Registered
2016-2018 Range Rover Sport
Joined
·
297 Posts
Congrats!
I can comment on the sound.
That crackling has been an issue on the FPace I have. It was fixed with a software update.
http://www.fpaceforum.com/#/topics/32089

It was fixed for me but other members have not had the same results.

I know what you mean. The cracklings is unbearable!
I noticed the smell too. I hope it’ll just go away after time.



Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
42 Posts
The cup holder does slide easily, but I am able to use both holders. I also did notice a strange smell at first coming from the engine but it didappeared after the first week. No problems with the sound system.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
Thanks for the info, odd that it should slide as easily as it does. If dealer doesn’t address I’m going to make a mod to it.. I’ll leverage a a small magnetic latch under the back edge.
 

·
Registered
Joined
·
59 Posts
My cupholders slide but mine definitely stay put even when braking hard and such....they've never moved. The cover also slides back far enough that I can use both cupholders.

I don't have the cracking/popping but I do have a very odd whine from the speakers, usually within the first few minutes after startup. I thought at first it was a whine that was tied to engine RPMs (throw back to old days when you didn't have a clean power/ground line for your radio) but I eliminated that....its consistent in pitch for the most part, cannot be turned off (even when turning off the media/putting speakers on mute. I will try changing the sound processor though to see if that works.

Haven't had the coolant smell but then again, I'm in a warmer climate where we use the A/C 365 days a year....:)
 
1 - 6 of 6 Posts
Top