RangeRovers.net Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter #1
This is the second time happened, when I backing up my RRS, I put in reverse gear, release the E-brake along with brake. The car wasn't moving at all. Feels like something stucked. I have to give a little bit gas to let it go. Then I heard a noise feels like I run over something. I can't find anything below the car. Do you guys ever experience this situation? I have a 2011 RRS gt edition with 44k miles. Thanks for all the inputs and help
 

·
Premium Member
2006-2009 Range Rover Sport
Joined
·
5,175 Posts
Sounds like your Electronic Parking Brake was stuck...cycle it a few times...you should be ok. You should hear the motor engaging and disengaging when you cycle it.
 

·
Registered
Joined
·
64 Posts
Discussion Starter #3
ok will do thanks,I thought there probably have issue with my tranny or axles
Sounds like your Electronic Parking Brake was stuck...cycle it a few times...you should be ok. You should hear the motor engaging and disengaging when you cycle it.
 

·
Premium Member
Joined
·
2,467 Posts
Sounds like you're still in factory warranty. I would take it in, and have them check out the parking brake shoes, these fail pretty quickly if stuck engaged and driven. It can turn into a costly repair that would be on your dime if it fails once you pass 50k miles.

There is also a chance that you just didn't hit the P/B switch enough, and it was still fully engaged(hadn't tried to disengage) As soon as the throttle registers a 3% input, and the transmission is in gear, it will automatically disengage the P/B. But still, with your time/mileage situation, I would plan a trip to the dealership anyway.
 
1 - 4 of 4 Posts
Top