Range Rovers Forum banner
1 - 5 of 5 Posts

· Registered
2014 Range Rover Sport Autobiography
Joined
·
220 Posts
Discussion Starter · #1 ·
Hopefully the video can help... engine at idle.


08 SC, 130k miles on the clock... I'm hoping it's the waterpump because that's where the noise seems to come from, although if it was the waterpump wouldn't it be leaking?

From what I can tell with the service history, waterpump is original, timing chain guides have never been done.

TIA!
 

· Registered
2014 Range Rover Sport Autobiography
Joined
·
220 Posts
Discussion Starter · #3 ·
Don't discount the idler pulley bearing right next to it. use a dowel or long screw driver as a stethoscope and narrow it down. As far as the water pump leaking... only if the front bearing were shot and it were oscillating and breaking the seal.
I plan on replacing all the pulleys when I do the belts, which is sooner rather than later now. Hopefully that'll be it.
 

· Registered
2014 Range Rover Sport Autobiography
Joined
·
220 Posts
Discussion Starter · #6 ·
Had time to take things apart today, it is the waterpump, same noise when turned by hand. Luckily it didn't start leaking or fail. I already received all the belts, tensioners, and pulleys, now to order a thermostat and pump.
 

· Registered
2014 Range Rover Sport Autobiography
Joined
·
220 Posts
Discussion Starter · #8 ·
Finally done, Parts bill: $353.89 Replaced every single pulley, both belts, water pump and thermostat. She should be good to go for another 100k :)She sounds so quiet now
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top