Range Rovers Forum banner
1 - 3 of 3 Posts

·
Registered
2013-2015 Range Rover MkIV / L405
Joined
·
23 Posts
Discussion Starter · #1 ·
I have a '06 RRS HSE. I just bought a NAV-TV VTC-RR USBCAN2 Land Rover Range Rover Sport 2005-up Nav-TV module off eBay. The parts include:

NAV tv VTC-RR

USBMOSTIR U:3 (fiber optics)

N-806 (filter)

I think the USBMOSTIR U:3 is for the addition of a 3.5mm jack but I don't think I'm goig to use it. I'm not sure what the N-806 filter is.



I'm hoping all I have to do is connect the VTC-RR module to get video-in-motion on the fron nav screen. I already have video on the front nav screen but it displays the safety message when I turn the vehicle on. I can view the DVD on the front screen in motion by inputting the 753 hack code. I used the Land Rover OEM fakra cable, S-Video cable and a couple Volkswagon Fakra antenna adaters to get video to the front nav screen. I have read too many posts and saw people sending there units to get a RCA video jack put on there RSE module. Do I need to send my RSE to Nav-TV to get video-in-motion even if I already have video on the front nav screen?

Thanks
 

·
LIFETIME CONTRIBUTOR
2006-2009 Range Rover Sport
Joined
·
11,015 Posts
If you wired the video cable correctly, you should be able to see DVD playback from the RSES on the front monitor's DVD sub-menu while the shifter is in Park. In that case, my understanding is that VTC-RR module installation is completely plug and play using the supplied harness, just find a place to tuck it behind the radio and that should be it, no need to return the RSES module to Nav-TV to retrofit the RCA out. The VTC module "tricks" the RSES to think you are still in Park even after you move the shifter to Drive, et voila, Video-In-Motion. :wink: If video won't play back on the front monitor while in Park and/or unless you use the 753 hack code however, something may have gone wrong during installation of the cable and adapter(s) between RSES and front touchscreen. Did you use the green Fakra connector behind the monitor? The other one (brown? Can't remember) is for a backup camera. Don't know what the filter you got is for, either.
 

·
Registered
2013-2015 Range Rover MkIV / L405
Joined
·
23 Posts
Discussion Starter · #3 ·
Thanks umbertob. The video will show when the ignition is in the "l" position but when turn the key is turned to the "ll" position, the safety message shows. I used the green connector on the nav screen. I bought the OEM Fakra cable from Land Rover but it was too short. If I remember correctly, I extended it with an S-Video cable from Radio Shack and a couple Volkswagon Fakra to DIN adapters from my local stereo shop. I think they're called aerial adapters. I don't think the video cable from the RSES to the Nav screen is the problem being the video works when the key is in the "l" position. I remember reading something about a software update a while back about a software update. I'll have to search for it. I'm hoping that's not the problem. I hate to have to pay the dealer $$$$$$$ for the software update. If the cable is the problem, do you know where I can get the complete cable without me having to change the pins on the S-Video side?
 
1 - 3 of 3 Posts
Top